Custom Texture Problem

Alright so right now im making custom textures for the new map im making. I’ve already installed VTF Edit, Paint.net, and Paint.net plugins. I started paint and went to work on the textures but when i press save as and change the file type, the file type .vtf isnt there. How can i add .vtf to the list?

Just save it as a targa and import it to VTFEdit, then save it as a vtf.

I tried that but VTF Edit only lets me open files that are vtf or vmf

You need to select the “import” option.

It’s the button that looks like a fresh sheet of paper.

Or file > import. Either way works.