Custom textures with Pointshop (TTT)

I’ve been trying to add custom trails to Pointshop for TTT but the pointshop always has the pink/black missing texture instead of my texture.

The .vtf and .vmt are in garrysmod/materials/shine/shine.vmt and shine.vtf and the .vmt has:



"UnlitGeneric"
{
"$basetexture" "shine" -- Also tried with materials/shine and shine/shine to no avail
"$vertexalpha" 1
"$vertexcolor" 1
"$translucent" 1
}


I have an autorun lua file in garrysmod/lua/autorun/server/custom.lua which has:



if (SERVER) then
	resource.AddFile('materials/shine/shine.vmt')
end


I have an item lua file in the pointshop in garrysmod/addons/pointshop/items/trails/shine.lua which has:



ITEM.Name = '20XX'
ITEM.Price = 250
ITEM.Material = 'shine/shine.vmt' -- Also tried with materials/shine to no avail

function ITEM:OnEquip(ply, modifications)
	ply.TubeTrail = util.SpriteTrail(ply, 0, modifications.color, false, 15, 1, 4, 0.125, self.Material)
end

function ITEM:OnHolster(ply)
	SafeRemoveEntity(ply.TubeTrail)
end

function ITEM:Modify(modifications)
	PS:ShowColorChooser(self, modifications)
end

function ITEM:OnModify(ply, modifications)
	SafeRemoveEntity(ply.TubeTrail)
	self:OnEquip(ply, modifications)
end


Can’t figure this out so I must be missing something stupid or obvious.

Bump? :mindblown:

Moved to developer discussion - you might get some more help here than in the previous section.

Since this is related to Pointshop this should have gone in Developer Discussion to start with.

The only thing I see wrong is your $basetexture should be shine/shine. Could you take a screenshot of the path to your vmt and vmf files?

Side question:

garrysmod/addons/pointshop/items/trails/shine.lua

to

garrysmod/addons/pointshop/lua/items/trails/shine.lua

Was that just a typo?

Another sidenote:

After you do the above, verify that you actually have the material on your client and that you restart your game. You can do this by checking the “download” folder and seeing if you can find the material in there.

My bad.

Tried shine/shine as stated in OP, didn’t work, but if that’s what it should be I’ll set it back.

And yes, it was a typo. It’s in with all the other Pointshop items.

Also yes, it was downloaded into my download/materials/shine folder.