Custom textures wont show up in Hammer; specific details in topic

Yeah, my custom textures wont show up in the Hammmer texture selector. Engine Version: The Orange Box. Current Game: Half-Life 2: Episode Two. Here’s the exact directory I put one of them in:

C:\Program Files\Steam\steamapps\laharlsblade\half-life 2\hl2\materials\reflective_floor

The two files in there are: wood_plain.vmt and wood_plain.vtf, 1 KB and 342 KB respectively. Here’s the code for the .vmt:

“LightmappedGeneric”
{
“$basetexture” “reflective_floor/wood_plain”
“$bumpmap” “reflective_floor/wood_plain”
“$basetexture2” “reflective_floor/wood_plain”
“$bumpmap2” “reflective_floor/wood_plain”
“$envmap” “reflective_floor/wood_plain”
“$envmapmask” “reflective_floor/wood_plain”
“$detail” “reflective_floor/wood_plain”
“%tooltexture” “reflective_floor/wood_plain”
“$normalmap” “reflective_floor/wood_plain”
“$dudvmap” “reflective_floor/wood_plain”
“%keywords” “reflect”
“$translucent” 1
}

It’s not in there whether I change it to All textures or Materials. Btw if you’re wondering why wood_plain is in reflective_floor it’s because I downloaded that texture from that interloper tut. that texture shows up, but none of the other numerous textures I have in that folder. Any help would be greatly appreciated.

[editline]09:30PM[/editline]

Oh and I saw that adding custom textures in Hammer topic, but that didn’t work either. It’s just that the reflective floor does show up, so Im a bit perplexed as to why the others don’t.

Why do you have two basetextures? that only works on “worldvertextransition”

I do? Oh yeah… will removing the second one fix it? BTW I’m not sure why, Im using VTFEdit to convert jpgs when necessary.

Just use $basetexture. You don’t need any any other texture tags.

Good God. Because you’re only using one texture, the only option required to point toward a texture is “$basetexture” Also “$translucent” 1 is only required if you’re using an alpha. Of course, if you really want it to be a “reflective_floor,” you need to make an $envmapmask texture.

Edit: Dammit

Well in vtfedit I just filled all the options with the right .vtf just in case. SO you’re saying it will work if I change that? Well I have to go to bed for the night but please help is still welcome and encouraged! And thanks for all your help so far.

This is all you need:


"LightmappedGeneric"
{
"$basetexture" "reflective_floor/wood_plain"
}


I shall try this.

[editline]03:18PM[/editline]

Well, actually I found the problem, but that wasn’t it. I already had other textures in that folder with that exact code only with the name changed to fit correctly, and they didn’t show up either. I was looking around my folders after they didn’t work, and found that I needed to also put them in:

C:\Program Files\Steam\steamapps\laharlsblade\half-life 2 episode two\ep2\materials

Thanks for your help anyways though guys.