Customizable Weaponry 2 Wont Install

So, recently (Like a few months ago) I’ve been trying to add Cw2 (Customizable Weaponry 2) and it’s not showing up in any sort in weapons.
I have a few LUA errors that im pretty sure make it this way. But I want to know how to fix it.
Heres the errors.

[lua]
[ERROR] addons/cw2/lua/weapons/cw_ak74/shared.lua:1: attempt to call global ‘ddCSLuaFile’ (a nil value)

  1. unknown - addons/cw2/lua/weapons/cw_ak74/shared.lua:1

[ERROR] addons/cw2/lua/weapons/cw_ar15/shared.lua:1: attempt to call global ‘ddCSLuaFile’ (a nil value)

  1. unknown - addons/cw2/lua/weapons/cw_ar15/shared.lua:1

[ERROR] addons/cw2/lua/weapons/cw_base/shared.lua:1: unexpected symbol near ‘-’

  1. unknown - addons/cw2/lua/weapons/cw_base/shared.lua:0

[ERROR] addons/cw2/lua/weapons/cw_deagle/shared.lua:135: malformed number near ‘3.4C’

  1. unknown - addons/cw2/lua/weapons/cw_deagle/shared.lua:0

[ERROR] addons/cw2/lua/weapons/cw_g3a3/shared.lua:181: malformed number near ‘4.85C’

  1. unknown - addons/cw2/lua/weapons/cw_g3a3/shared.lua:0

[ERROR] addons/cw2/lua/weapons/cw_mp5/shared.lua:180: malformed number near ‘3.5C’

  1. unknown - addons/cw2/lua/weapons/cw_mp5/shared.lua:0

[ERROR] addons/cw2/lua/weapons/cw_mr96/shared.lua:102: unfinished string near ‘<eof>’

  1. unknown - addons/cw2/lua/weapons/cw_mr96/shared.lua:0
    [/lua]

Any help is appreciated. :slight_smile:

Edit: It doesent work when I reinstall the addons, so dont ask!
Edit 2: I didnt mess around AT ALL with the files. So dont ask about that either!

First of all, where did you download it from? Last time I checked it is a Workshop addon, not a folder/legacy/filesystem addon.

I downloaded it through steam workshop. But I use gmodconv to extract it. (No clue if its that.)

It looks like whatever you used to extract it corrupted the file text

Any way i could fix it?
Btw I used gmodconv (Its basically a drag and drop GMA extractor)

The default .gma extractor is drag’n’drop for like half a year by now.

Use this instead. It’s a nice GUI alternative to the drag’n’drop method.

I have it and tried to use it. It was probably the first thing i tried…
Not to mention it doesent like to work with my computer,
It basically doesent list the addons. I have to browse every time…

That’s because your Steam directory isn’t where it normally is.
Open it, click “Open” (top left) and then “Browse” (bottom right) then navigate to your GMod addons folder and extract .gma there :smiley:

Not sure why it wouldnt pick it up, I havent moved it at all.