Dark RP - Mayor Commands "You arent in the right team to access these commands"

I try to do any type of mayor command I get a denied message somewhere along the lines of “You arent in the right team to access these commands”.

Add this to the mayor job in the shared.lua

“mayor = true,”

It should work then.

That worked partially, i still cant initiate a lottery or place the law board.

Edit: In my config

– lottery - Enable/disable creating lotteries for mayors
GM.Config.lottery = true

Also, for dedicated DarkRP help, take a look at the official forums: http://forum.darkrp.com
FPtje and Bo (Major DarkRP contributor) are heloing there.

cough Has no population Cough Just use FacePunch Cough

I’ve said this several times: People can use whatever they want, we’re not forcing anyone (same goes for the Wikis). The forums is two days old, what amount of threads and posts do you expect?

FPtje and Bo are both active and helping people, as well as other community members in the future. It makes it easier for Players and Server Owners to find DarkRP related posts. I am there as well, helping with DarkRP server related SRCDS questions/problems.

Once again: Feel free to use it if you want to, if not, simply don’t use it.

BUMP, lets get back to the original topic

What happens when you try to place a lawboard or start a lottery? What does it say?

Ok… my lottery now randomly works, but the laws just type /placelaws in my chatbox.

[editline]28th August 2013[/editline]

now my jail positions dont work and just say /setjailpos.

Have you checked the server console for errors?

Yes nothing pertaining to mayor stuff.

But any Lua error could possibly lead to other problems.

There is one, it leads to gamemode_functions line 80

BUMP

Without giving the error there’s not much we can do…

L 08/26/2013 - 22:52:50: Lua Error:
[ERROR] gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80: attempt to call field ‘Init’ (a nil value)

  1. Call - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80
  2. unknown - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:880

[ERROR] gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80: attempt to call field ‘Init’ (a nil value)

  1. Call - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80
  2. unknown - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:880

Nav File is wrong or something (1)

/

[ERROR] gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80: attempt to call field ‘Init’ (a nil value)

  1. Call - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80
  2. unknown - gamemodes/darkrp/gamemode/server/database.lua:33

[ERROR] gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80: attempt to call field ‘Init’ (a nil value)

  1. Call - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80
  2. unknown - gamemodes/darkrp/gamemode/server/database.lua:33

Timer Failed! [Simple][@gamemodes/darkrp/gamemode/server/database.lua (line 31)]

/

[ERROR] gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80: attempt to call field ‘Init’ (a nil value)

  1. Call - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80
  2. InitPostEntity - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:880
    3. unknown - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:914

[ERROR] gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80: attempt to call field ‘Init’ (a nil value)

  1. Call - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:80
  2. InitPostEntity - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:880
    3. unknown - gamemodes/darkrp/gamemode/server/gamemode_functions.lua:914

Timer Failed! [Simple][@gamemodes/darkrp/gamemode/server/gamemode_functions.lua (line 912)]

Looks like something’s going wrong with FPP.

Fixed the lawboards. /setjailpos still comes up.

Did you delete the FPP folder or something? Those errors show DarkRP not finding FPP.

Nope havent touched them.