DarkRP 2.4.2 problem: Cannot see the names of people when aiming at them

I have a friend who was trying to play DarkRP 2.4.2 with me but was complaining about not being able to see the names of people when he aimed at them. It didn’t show him what ‘class’ the person was nor the name of the person. I’ve google’d this to some extent for him but I haven’t gotten very lucky finding and addressing the problem, I thought the easiest way would be to ask you guys over here on Facepunch.

I would greatly appreciate it if anybody could offer me some assistance on the matter, also if you have questions about necessary information I will gladly comply.

On a final note what we have tried is verifying his game cache and also joining a different DarkRP 2.4.2 server and neither have done anything.

You are sure it’s not serverside? Check if he have any addons. Try to remove them and see if the problem persists.

I used to have this problem, does the server use madcows? If so, try installing that as it’s what worked for me.