DarkRP ATM Gmod 13 can't deposit or withdraw

Hi everyone,

I have installed ATM v3 for Gmod 13 installed on my server but nobody can’t deposit or withdraw money with the ATM.
I’m using DarkRP beta but even on the stable version it doesn’t work.

This is the error:

http://static.afbeeldinguploaden.nl/1309/45806/081EHjn5.png

init.lua:85:


	if ( IsValid( target ) && math.floor( args[3] ) >= 0 and target.DarkRPVars.money - math.floor( args[3] ) >= 0 and args[1] == util.CRC( target:GetPData( "pin" ) ) ) then
Line 85>	pl:AddMoney( -args[3] )
		target:SetPData( "bankmoney", target:GetPData( "bankmoney" ) + math.floor( args[3] ) )
		pl:ConCommand( "rp_atm_account " .. args[1] .. " "  .. args[2] .. " " .. target:GetPData( "bankmoney" ) )
	else
		pl:ChatPrint( "Error occured!" )
	end
end )

concommand.lua:69:


--[[---------------------------------------------------------
   Name: concommand.Run( )
   Desc: Called by the engine when an unknown console command is run
-----------------------------------------------------------]]
function Run( player, command, arguments, args )

	local LowerCommand = string.lower( command )

	if ( CommandList[ LowerCommand ] != nil ) then
Line 69>	CommandList[ LowerCommand ]( player, command, arguments, args )
		return true
	end

	if ( player:IsValid() ) then
		player:ChatPrint( "Unknown Command: '" .. command .. "'
" )
	end
	
	return false;
end

Does somebody knows how to fix this?

Thanks Android

AddMoney doesn’t exist in new version apparently, you’ll have to find what it is now and replace it.

It’s probably addMoney or addmoney.

According to my badly hacked together ATM, it’s


ply:addMoney(amount)

http://forum.darkrp.com/threads/atm-banker-v3-help-with-addon-lua-errors.98/
Here you go.

Thanks all I will try those things :slight_smile: