DarkRP cant update CSS

Hey guys, im pretty new to this forum so i dont know if this is the right section.
But since new i tried to come back to the Server making in GMod with DarkRP again.
What i needed and what it said was that i need the css files.
I tried to do it with the hldsupdatetool through cmd like this: c:\srcds>hldsupdatetool -command update -game “Counter-Strike Source” -dir .
Also through a batch file the same way.
But in either way it stops working after it shows me a list with some weird games for 3 seconds and it closes itself.
I couldnt fix this so i took the cstrike folder of the Counter Strike Source beta folder.
But the money is floating in middair and thats what first comes weird to me and i cant even pick it up.
Any suggestions? I need help quick and i dont know how to fix this issue.

Sounds like something is wrong with the models for the money by chance. Maybe a missing file or a corrupt file for one of the models. I would probably try grabbing CSS content from the newest version of CSS rather than beta…

Yeah well the money might fix if i get the newer version.
But i tried to run a Batch file with this code in it: HldsUpdateTool.exe -command update -game “Counter-Strike Source” -dir.
And it started the HldsUpdateTool but ended IMMIEDIATE after it showed me a list of some games i dont realy know.
I tried to do that with HldsUpdateTool.exe -command update -game cstrike -dir . and it worked in another folder. Though it didnt fix the money problem.
I also tried to do it in different folders different ways etc. but nothing seems to work.
So i need help with that whenever i try to get the new version from CSS through the Update tool it crashes instantly and thats my problem. Any suggestions? :frowning:

EDIT:
Oh and, only the money currently floats. Weapons work fine! What is wrong? :frowning:

Don’t use HLDS, use SteamCMD. HLDS is outdated.

Where do i get SteamCMD from?

EDIT:
Nvm got it, but how do i download CSS through it?

EDIT²:
Okay, till now everything works fine, downloading the CSS files now, going to continue and if i need any more help or have questions ill rather ask them in here so if you can leave this thread open for now since i could need it again. Thanks guys! :wink:

EDIT³:

The Money is still floating in air!
After i try it it shows me this:

[ERROR] gamemodes/darkrp/entities/entities/spawned_money/init.lua:17: Tried to use invalid object <type IPhysicsObject> <Object was NULL or not of the right type>

  1. Wake - [C]:-1
  2. unknown - gamemodes/darkrp/entities/entities/spawned_money/init.lua:17
    3.Spawn - [C]:-1
  3. DarkRPCreateMoneyBag - gamemodes/darkrp/entities/entities/spawned_money/init.lua:33
  4. unknown - gamemodes/darkrp/gamemode/server/main.lua:1245

OK, you may need to move the ‘css’ folder from inside the ‘orangebox’ folder to outside it.

for example:

Css would be here:
Documents>Server>Orangebox>CSS

To:
Documents>Server>CSS

(So it’s in the same directory as 'Orangebox)

Didnt work either, i do this with SteamCMD:
login anonymous
->
force_install_dir C:\srcds
->
app_update 232330

Then it installs that things, also i got the cstrike folder IN orangebox and OUT orangebox still no success. Not to mention it installs everything seperate (Meaning folders like cstrike,bin,hl2 are seperate in the srcds folder)

Can someone help me with how to install css properly to DarkRP ? :frowning:

It also looks as if there’s some root DarkRP errors…
Who and when installed this?

Do you have the Dark RP SVN? It’s always the most updated version.