DarkRP Class errors. How can I fix this?

Hi, I’m sorry if this wastes you time but I’m in need of assistance with these DarkRP Classes. The problem is that the calles are stuck in a T-like formation.

Like this:

http://www.technetiumcorp.com/images/rp_downtown_v20002.jpg

This is the code:


TEAM_SALE = AddExtraTeam("Illegal Weapon Salesman", Color(205,102,51,255), "models/player/t_guerilla.mdl", [[Sell your guns! 
Dont get Caught!!!]], {"weapon_mad_deagle", "weapon_mad_fists"}, "illegal", 2, 45, 0, false, false, TEAM_SALE)

How do I fix this?? I’ve tried everyway I know how. Please help…

You’re using CSS player models. Use guerilla instead of t_guerilla.

Thank you! It fixed it. Now how do I fix them from walking backwards? o_O

DarkRP Is so badly scripted… someone needs to make a new one…

[editline]30th December 2011[/editline]

This is the next error that I keep getting:

http://technetiumcorp.com/images/rp_downtown_v20000.jpg

It happens when I choose the job Gun Dealer and press f4 again. Thats a best picture I could get.

I’m sorry for all this help that I’m needing and if I’m wasting your time… This normally never happens.

Are you sure that you got DarkRP from a SVN? It seems like the GUI is a bit outdated.

EDIT: I think this belong to the “Questions” thread

Here’s the code for that error line… Not sure if it will help.


for k,v in pairs(DarkRPEntities) do
						if not v.allowed or (type(v.allowed) == "table" and table.HasValue(v.allowed, LocalPlayer():Team())) 
							and (not v.customCheck or (v.customCheck and v.customCheck(LocalPlayer()))) then
							local cmdname = string.gsub(v.ent, " ", "_")
							

[editline]30th December 2011[/editline]

Yes it’s right from the svn… and I even updated it. nothing has changed. Why make a new post in another thread this is all the same issue…

I’m confused on why you have the prerequisite of “TEAM_SALE” requires you be apart of “TEAM_SALE”.

TEAM_SALE is the illegal Weapon Salesman. So I shortened it to TEAM_SALE.

Update your gamemode before you ask for help, updates are released for a reason, you know.

I have updated my gamemode buddy… Many times. Done nothing to fix it.

Post your full shared.lua and addentities.lua

They are too large to post so here are the links to them

In addentities.lua, find:

[lua]AddEntity(“Microwave”, “microwave”, “models/props/cs_office/microwave.mdl”, 400, 1, “/buymicrowave”, TEAM_COOK, TEAM_ADMIN)
AddEntity(“Gun lab”, “gunlab”, “models/props_c17/TrapPropeller_Engine.mdl”, 500, 1, “/buygunlab”, TEAM_GUN, TEAM_ADMIN)[/lua]

Change to:

[lua]
AddEntity(“Microwave”, “microwave”, “models/props/cs_office/microwave.mdl”, 400, 1, “/buymicrowave”, {TEAM_COOK, TEAM_ADMIN})
AddEntity(“Gun lab”, “gunlab”, “models/props_c17/TrapPropeller_Engine.mdl”, 500, 1, “/buygunlab”, {TEAM_GUN, TEAM_ADMIN})[/lua]

Omg why is it now that none of my shipments are showing up? Jesus I can’t win. ⌐_⌐

Nevermind… I found out why. Thanks guys for all the help…