DarkRP Entity Problem

I am currently creating a server on Gary’s Mod for the gamemode of DarkRP. I have run into a problem though. WHen people buy a printer of a boombox and then it gets destroyed or removed by a admin they can no longer buy more. The limit on the gemstone money printers is 2 per person. If even I buy 2 and blow them up I can not buy more. If the DJ job buys a boombox and changes jobs back and forth so it removes it they can not buy another one. The error I get is “[DarkRP] You have reached the Sapphire Printer limit!” in console. In the bottom right the red X and the text pops up though. If anyone knows a way to fix this I have already tried reinstalling darkrp with no prevail. Thank you

Have you tried to check the “config” file from the printers ?
Can you upload screenshots of the error and the config file ?

Here is the screenshot from in game
http://steamcommunity.com/sharedfiles/filedetails/?id=671490154
And in the config file it has nothing on the subject, This is also happening to the boombox entity also so I don’t think its in the printer config.
http://tinypic.com/r/op6zr5/9
http://tinypic.com/r/2mcf6dg/9

Do you get this error with other entities you bought ?

The only other entity then the printers is the boombox and it also has the problem
All entities have the problem.

Try to set see below in “server.cfg” which is in “garrysmod/cfg/”

That is not the problem. The printers and entity’s bought in the f4 menu will not allow you to re-buy them once removed in any way. It sais you already have reached the limit. Therefore darkrp must not be registering them getting deleted. I have already tried reinstalling darkrp modification and darkrp gamemode with no prevail

Maybe a script issue or addon who conflicting with another one ?
Maybe the printer or/and the boombox is/are broken ?

The printer and boombox are not broken and I think it might be an addon conflicting