DarkRP - Everything broken?

Ok this happened a while ago. I don’t know anymore what to do to fix it. I leave it to you guys if someone of you can tell me what to do, i’ll fix it:

Console Prints


Lua Error: [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:532: attempt to index a nil value 1. initPlayer - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:532 2. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:557


Lua Error: [DarkRP] gamemodes/darkrp/gamemode/modules/doorsystem/sv_doors.lua:59: attempt to perform arithmetic on field 'OwnedNumz' (a nil value) 1. keysOwn - gamemodes/darkrp/gamemode/modules/doorsystem/sv_doors.lua:59 2. callback - gamemodes/darkrp/gamemode/modules/doorsystem/sv_doors.lua:385 3. unknown - gamemodes/darkrp/gamemode/modules/chat/sv_chat.lua:149 4. unknown - lua/includes/modules/concommand.lua:69


Lua Error: [DarkRP] lua/includes/modules/player_manager.lua:63: bad argument #1 to 'lower' (string expected, got nil) 1. lower - [C]:-1 2. TranslateToPlayerModelName - lua/includes/modules/player_manager.lua:63 3. RunClass - gamemodes/darkrp/gamemode/modules/base/sh_playerclass.lua:11 4. Call - gamemodes/base/gamemode/player.lua:290 5. DoSetup - gamemodes/base/entities/entities/gmod_hands.lua:25 6. SetupHands - lua/includes/extensions/player.lua:202 7. PlayerSpawn - gamemodes/base/gamemode/player.lua:261 8. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:660

I’ll post more errors if i get them printed up. Files:

sv_gamemode_functions.lua

Did you change GAMEMODE.DefaultTeam?

Where is that at?

Bump

If youre using the mod addon it would be in jobs.lua

If not, its gamemodes/darkrp/gamemode/config/jobrelated.lua

GAMEMODE.DefaultTeam = TEAM_CITIZEN

Nope. Untouched. Also if needed here’s my jobs.lua file:

jobs.lua

You haven’t used DarkRPModification, as it says in the file. Reinstall darkrp and get this. Follow the instructions on the github page.

We used DarkRP Modification. The server is not so new. It has its time and it had jobs. For some reason this happened, but i use DarkRPModification-Master

Reinstall the GMA file, the one in garrysmod/gamemodes or both of them?