DarkRP - F4 menu admin tab not working

Hello. I have opened this thread to aid the assistance of someone to help me fix my DarkRP on my Garrysmod server. I have a issue whereas the variable commands in the admin tab of the F4 menu do not work. Both tick box and scroll-er options. For example: “rp_allowgundealers”. This command is based on a YES/NO system. 1 being YES. 0 being NO. On past servers it has clicking the little box has worked for me and changed the variable from either 1 to 0, or 0 to 1. But, on my new server, it is not working. When I tick / un-tick the box, or move a scroll-er it does not work and the command does not get activated. This is the same if I paste the code directly in the console. To get the variable to change, I have to first enter my RCON password into the server and then enter the command in-front of RCON. Example: “rcon rp_allowgundealers 1”. That is the only way to make the variable change.

I was wandering if anyone can help me fix this so that the variable can be changed from normally just by clicking the little check box or moving the slider in the “admin” section of the F4 DarkRP menu. I simple cannot go through and type every code 1 by 1 in the console setting them to there appropriate variable. There are hundreds. It would take hours.

Can anyone help / tell me how to fix / tell me what the problem is?
Thanks in advance.

2 Things.

  1. DarkRP, Really?

  2. What admin mod are you using and what rank are you set as.

I’m pretty sure you have some other addon/mod interfering with it. DarkRP wouldn’t do that on it’s own.

Try deleting any admin mods/addons you have for now, restart the server, and see if it worked. If so, change what you need, then put the stuff back onto the server.

Listen, even IF it is crap, there are still alot of people enjoying this gamemode. There is nothing wrong with the gamemode itself, unless some “lua gods” go check the code and all say that it is crappy.
Let the people who play it be happy. If it was so crappy, why is it one of the most used gamemodes in GMod? Look in the server browser, TONS of servers running DarkRP.
Why? Easy to install, easy to customize. That’s why.

Where did you get your DarkRP from? If you downloaded it from garrysmod.org, remove it and update to the SVN.


That’s a pretty darn good answer. And that for a guy with only 6 posts.

If you want any help: I have no experience with LUA, but you can add me to your Steam friends. I can help troubleshoot and it definatly works faster than on a forum.

I fixed it. I got the SVN of the new DarkRP and used that. It was a bitch though. I had to implement all of my custom LUA scripts from my old DarkRP into my new one. Which took about 4 hours. But, I did it. With a bit of persistence.

Thank you guys for your help.