DarkRP Fail or Server Fail?

K, so I have been running a darkrp for a while now, and it has had its ups and downs due to updates. But this last update killed it. DarkRP is not initializing correctly, and the q menu does not work for players on the server. This had happened before when the datastream update messed everything up. I resolved it with the datastream fix, then we had another update, so I removed the fix which allowed my server to continue running just fine on the fixed gmod datastream. Now, however, I have problems. Here is my console:



256.0 fps  0/21 on map rp_cscdesert_v2-1_propfix
Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game.dll loaded for "Garry's Mod"
Mounting hl2.. OK
Mounting ep2.. Failed
Mounting tf.. OK
Mounting cstrike.. OK
Mounting dod.. OK
Mounting episodic.. OK
Mounting hl2mp.. OK
Mounting portal.. Failed
Mounting lostcoast.. OK
Mounting hl1.. Failed
Mounting hl1mp.. Failed
Mounting zeno_clash.. Failed
Parent cvar in server.dll not allowed (sk_apc_missile_damage)
Parent cvar in server.dll not allowed (bot_mimic)
Garry's Mod server.dll Build #086 [Jun 29 2010 20:16:17]
maxplayers set to 21
Unknown command "sv_allow_wait_command"
Unknown command "cl_interp"
Network: IP 10.0.1.130, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Unknown command "sv_unlag_fixstuck"
***need to set $abovewater for material maps/rp_cscdesert_v2/dev/dev_water2_cheap_1984_-8768_-272
***need to set $abovewater for material maps/rp_cscdesert_v2/dev/dev_water2_cheap_1984_-8768_-272
***need to set $abovewater for material maps/rp_cscdesert_v2/dev/dev_water2_cheap_1984_-9040_-256
***need to set $abovewater for material maps/rp_cscdesert_v2/dev/dev_water2_cheap_1984_-9040_-256
Lua initialized (Lua 5.1)
[UTeam Error] UTeam config file missing.
======== Installing Table (De)Serialiser Module | ver: 1.4 ========
///////////////////////////////
//      Ulysses Library      //
///////////////////////////////
// Loading...                //
//  shared/defines.lua       //
//  server/hook.lua          //
//  server/gamemode_hooks.lua//
//  shared/misc.lua          //
//  shared/util.lua          //
//  shared/table.lua         //
//  shared/player.lua        //
//  server/player.lua        //
WARNING: Mismatched quotes in ULib.splitArgs
WARNING: Mismatched quotes in ULib.splitArgs
//  shared/messages.lua      //
//  shared/concommand.lua    //
//  server/concommand.lua    //
//  server/util.lua          //
//  shared/sh_ucl.lua        //
//  server/ucl.lua           //
//  server/phys.lua          //
//  server/player_ext.lua    //
//  server/entity_ext.lua    //
// Load Complete!            //
///////////////////////////////
[ULIB] Loading SHARED module: ulx_init.lua
///////////////////////////////
//       ULX Admin Mod       //
///////////////////////////////
// Loading...                //
//  sh_defines.lua           //
//  lib.lua                  //
//  base.lua                 //
//  log.lua                  //
//  MODULE: chat.lua         //
//  MODULE: fun.lua          //
//  MODULE: menus.lua        //
//  MODULE: rcon.lua         //
//  MODULE: slots.lua        //
//  MODULE: teleport.lua     //
//  MODULE: toolmode.lua     //
//  MODULE: user.lua         //
//  MODULE: util.lua         //
//  MODULE: vote.lua         //
//  MODULE: votemap.lua      //
//  MODULE: cleardecals.lua  //
//  MODULE: superpowers.lua  //
//  MODULE: userhelp.lua     //
//  end.lua                  //
// Load Complete!            //
///////////////////////////////
================================
===  Wire  2137 (exported)   Installed  ===
================================
======== Beam NetVars Lib v0.71 Installed ========
ERROR! Module 'zlib_b64' not found!
==== Advanced Duplicator v.1.72 shared module installed! ====
Added EntCheckHook: AdvDupe_NoItems
Added EntCheckHook: AdvDupe_DisallowedClasses
Added EntCheckHook: AdvDupe_ModelCheck
==== Advanced Duplicator v.1.85 server module installed! ====
Registering gamemode 'sandbox' derived from 'base'
ScriptEnforce is disabled
Loading Wire Tools
Compressing lua files into data pack..
Skipped. Datapack exists.                          <---------
Writing cfg/banned_user.cfg.
Executing dedicated server config file
Couldn't find scene 'scenes/npc/female01/question21.vcd'
Couldn't find scene 'scenes/npc/female01/question31.vcd'
Couldn't find scene 'scenes/npc/female01/answer35.vcd'
Couldn't find scene 'scenes/npc/female01/gordead_ques03a.vcd'
Couldn't find scene 'scenes/npc/female01/gordead_ques03b.vcd'
Couldn't find scene 'scenes/npc/female01/nice.vcd'
Couldn't find scene 'scenes/npc/male01/nice01.vcd'
Couldn't find scene 'scenes/npc/male01/nice02.vcd'
Couldn't find scene 'scenes/npc/female01/oneforme.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_run.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_ohshit.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_thisisbad.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_headcrabs.vcd'
Failed to load Steam ServiceServiceStart: failed to startUnknown command "rp_alltalk"
Unknown command "rp_bannedprops"
Unknown command "rp_copscanunfreeze"
Unknown command "rp_showdeaths"
Unknown command "rp_foodspawn"
Unknown command "rp_hungermod"
Unknown command "rp_ironshoot"
Unknown command "rp_restrictbuypistol"
Unknown command "rp_removeclassitems"
Unknown command "rp_strictsuicide"
Unknown command "rp_voiceradius"
Unknown command "rp_dm_autokick"
Unknown command "rp_ammopistolcost"
Unknown command "rp_quakechance_1_in"
Unknown command "rp_maxvehicles"
Unknown command "rp_advertisements"
Server logging enabled.
Server logging data to file logs\L0701000.log
L 07/01/2010 - 14:24:03: Log file started (file "logs\L0701000.log") (game "C:\srcds\orangebox\garrysmod") (version "4248")
Connection to Steam servers successful.
   VAC secure mode is activated.



I have put an arrow pointing at what I believe to be the problem. I do not have the datastream fix installed, so what the hell is going on?

EDIT: I just tried “ulx map rp_cscdesert_v2-1_propfix darkrp” and that worked. It loaded the gamemode. So my server.cfg is not loading it automatically anymore. I am going to investigate.

EDIT2: I tried starting the server, then typing sv_gamemode to see if darkrp was even being loaded. It says darkrp is running, but it is most definitely not. I think when I start my server for the first time, it thinks it has a datapack already but it doesn’t. What do I do?

Are you serious? If you think it’s the datapack, then you shouldn’t be running a server. It’s probably the engine update…

The engine update most likely caused a problem with the datapack. Unless you have a suggestion on how to fix it, i’d prefer if you kept your comments to yourself.

No! The datapack has NOTHING to do with the problem. Datapack is just what gets sent to the client, and since the content has already been packed, there is no need to do it again, I’m just telling you not to be searching for a fix with the datapack.

EDIT: The error happens before the datapack, looks like DarkRP doesn’t even attempt to derive from Sandbox. Do you have the proper run.bat?

Yes. I apologize for misreading your reply. Yes, I will copy my server.cfg and start.bat into this message:



@echo off
cls
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait /high srcds.exe -console -game garrysmod +map rp_cscdesert_v2-1_propfix +gamemode DarkRP -maxplayers 21 -autoupdate
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds




	"hostname"				"Jaspers Serious RP [DurgzMod | PCMOD2 | PHX | WireSVN]"
    "rcon_password" 		"ITS A SECRET!!!!" 
    "sv_password" 			""
	"sv_region" 			"255" // eastcoast: 0 - westcoast: 1 - south america: 2 - europe: 3 - asia: 4 - australia: 5 - middle east: 6 - africa: 7 - world: 255
	"sv_lan"				"0"
	"sv_gamemode"			"darkrp"
	//"sv_maxrate"			"192"

// Sandbox server settings
	
	"sbox_godmode"				"0"
	"sbox_plpldamage"			"0"  // set this to 1 to disable player vs player damage.
	"mp_flashlight"				"1" 
	"sbox_noclip"				"0"
	"mp_falldamage"				"1"
	"net_maxfilesize"			"128"

// Sandbox limits
	"sbox_maxprops"			"60"
	"sbox_maxragdolls"		"0"
	"sbox_maxnpcs"			"0"
	"sbox_maxballoons"		"0"
	"sbox_maxeffects"		"0"
	"sbox_maxdynamite"		"0"
	"sbox_maxlamps"			"2"
	"sbox_maxlights"		"5"
	"sbox_maxthrusters"		"500"
	"sbox_maxwheels"		"500"
	"sbox_maxhoverballs"	"5"
	"sbox_maxvehicles"		"0"
	"sbox_maxbuttons"		"500"
	
	"sbox_maxemitters"		"2"
	"sbox_maxspawners"		"0"
	"sbox_maxturrets"		"2"
	
//WIRE LMITS
	
	"sbox_maxwire_thrusters""30"
	"sbox_maxwire_emitters"	"20"
	
	
//ULX ADMIN COMMANDS
	"ulx" "logEcho"				"0" 				// Echo mode
												// Echo modes:
												// 0 - OFF No output to players when an admin command is used
												// 1 - FULL Output to players similar to "Foo slapped Bob with 0 damage"
												
												
//DARKRP!!!
	"rp_alltalk"				"0"
//	"rp_bannedprops"			"1"
	"rp_copscanunfreeze"		"0"
	"rp_showdeaths"				"0"
	"rp_foodspawn"				"0"
	"rp_hungermod"				"0"
	"rp_ironshoot"				"0"
	"rp_restrictbuypistol"		"1"
	"rp_removeclassitems"		"0"
	"rp_strictsuicide"			"1"
	"rp_voiceradius"			"1"
	"rp_dm_autokick"			"0"
	"rp_ammopistolcost"			"20"
	"rp_quakechance_1_in"		"2"
	"rp_maxvehicles"			"2"
	"rp_advertisements"			"0"
	
	
//LOGS!!!!!!!!!!
	"log" "on" 						               	//Creates a logfile (Enable= on Disable= off)
	"sv_logfile" 				"1"            		//Log server information in the log file.
	"sv_logsdir" "				"C:\srcds\orangebox\garrysmod\cfg\LOGS"    //Folder in the game directory where server logs will be stored.
	"sv_logecho"				"0" 	          	 //Echo log information to the console.
	"sv_log_onefile" 			"1" 		      	 //Log server information to only one file.
	"sv_logbans"				"1" 	          	 //Log server bans in the server logs.
	"sv_logdownloadlist"	 	"1"		          	 //Log files to download.







Well you can try a more simple run.bat, but since it worked before I don’t know why it wouldn’t work again. So make a backup of that run.bat and instead put:


c:\srcds\orangebox\srcds.exe -console -game garrysmod +map gm_construct -maxplayers 16 -autoupdate +sv_defaultgamemode DarkRP

And see if the gamemode loads.

EDIT: TBH, I think it’s the DarkRP version, make sure you have the most recent version, because every gamemode had to be recoded after the update, and if it isn’t the recoded version it won’t work, and that could be why it doesn’t derive.

I have not tried the batch yet, but I do have the latest version of darkrp (rev. 654). Also, there haven’t been any complaints on the dev forum on googlecode. Could there be something with a lua error stopping darkrp from loading? I really can’t figure out what though. Where can I find the order of files my server starts? For example, if I had made a mistake at the end of my server.cfg, could that stop it from loading darkrp? I haven’t changed these since the update, but I did have them open in notepad++ so i could have accidentally added a character at some point.

EDIT: Okay, so the new start.bat worked, I have modified the gamemode modifier in my other start.bat, so it should work now if I use the sv_defaultgamemode setting. Now the problem I have is that my server is using a teamfortress 2 motd. My ULX motd looks as it should, but ingame I see the teamfortress motd. I don’t even own tf2. I have it preloaded so I can use the content, but I never bought it.

EDIT2: Alright. Thank you for your help. I believe I am on the right track now. The MOTD fails were caused by the MOTD in each different folder in my orangebox folder. I have removed all of them, so we will see if my Gmod MOTD is going to work or not.

EDIT3: -_- Now no MOTD Shows up. Gonna see if there is a ULX update.

EDIT4: No update I can find. I guess no MOTD beats no server.