DarkRP Health Not working

Nothing else is wrong with my server I believe other than weapons do not do damage. You can prop-kill yes, but none of the weapons do damage… Do you guys have any idea what is causing this or how to fix? Maybe this will help: I recently tried to add custom ammo, in the main.lua file: Line 1195 But was unsuccesful… The ammo doesn’t work as an entity…

**if args ~= “9mm” and args ~= “12Guage” and args ~= “.30Car” and args ~= “.45acp” and args ~= “7.62mmr” and args ~= “7.62mmp” and args ~= “7.92mm” and args ~= “.30-06” then
Notify(ply, 1, 4, string.format(LANGUAGE.unavailable, “ammo”))
end

if not ply:CanAfford(GetConVarNumber("ammo" .. args .. "cost")) then
	Notify(ply, 1, 4, string.format(LANGUAGE.cant_afford, "ammo"))
	return ""
end

if args == "9mm" then //Name of the above arg...
	ply:GiveAmmo(80, "sim_fas_ammo_9mm")  //This is the name of the ammo entity...
elseif args == "12Guage" then
	ply:GiveAmmo(50, "sim_fas_ammo_bshot")
elseif args == ".30Car" then
	ply:GiveAmmo(50, "sim_fas_ammo_30car")
elseif args == ".45acp" then
	ply:GiveAmmo(50, "sim_fas_ammo_45")
elseif args == "7.62mmr" then
	ply:GiveAmmo(50, "sim_fas_ammo_762mm")
elseif args == "7.62mmp" then
	ply:GiveAmmo(50, "sim_fas_ammo_762pmm")
elseif args == "7.92mm" then
	ply:GiveAmmo(50, "sim_fas_ammo_792mm")
elseif args == ".30-06" then
	ply:GiveAmmo(50, "sim_fas_ammo_3006")
end

**

Could something like this fix iT? sv_pvpdamage 0

skanvilark, it is sbox_plpldamage 0.

This happened to my server too awhile ago, But it might be because your player vs player damage is disabled, you can enable it by holding tab and going to the server settings menu and there should be a button in there that says Player vs Player damage or something, just click that and it should enable it, another way to do it is to type in console sv_plpldamage 0, or you can do it with RCON too. Hope this helps.