DarkRP Hl2 HUD overlay HELP

This is what happens when i add my HUD , any help?

Nice hud, here’s what you are looking for: http://wiki.garrysmod.com/page/GM/HUDShouldDraw

Tyvm

Nvm, didn’t work, may i ask how i edit this in my server? i edited the file in cl_init but nothing changed.

This is something that custom HUD should handle, try look into the DarkRP modification addon, and look for cl_hud.lua or something, or try reinstalling that HUD.

Hm, my hud is for 1.4.3 so its Hud.lua, ive tried reinstalling alot, looked all over google but can’t find a solution. Other huds show the HL2 health overlapping too.

[editline]19th January 2014[/editline]

2.4.3*

Also tried re-installing DarkRP?

Yeah i did that

Must be client then, have you tried to see if someone else have the same problem?



function hidenorm(name)
    for k, v in pairs{"CHudHealth", "CHudBattery", "CHudAmmo", "CHudSecondaryAmmo"} do
        if name == v then return false end
    end
return true
end
hook.Add("HUDShouldDraw", "hidedefhud", hidenorm)


put that somewhere in your hud lua file. This is (for some reason) a common problem with this HUD. The dippy doo that wrote that HUD forgot it.

Well the person said it happens with all other HUD’s he use.

Yeah I put that in - No change.

Then you put it in the wrong place. It should be relative to “garrysmod\gamemodes\DarkRP\gamemode\modules\hud\cl_hud.lua”. That should be where your hud is, unless you use FPtje’s silly modification thing, in which case it’s probably something like “garrysmod\addons\darkrpmodification runk\lua\darkrp_modules\hudreplacement\cl_hudreplacement.lua”. If you really want, PM me for the full cl_hud.lua that my server uses (we use the EXACT SAME THING and had the EXACT SAME PROBLEM).

Ok, first of all if you dont have, download the darkrp-modification addon from here: https://github.com/FPtje/DarkRPModification
Place that into your addons folder
Open up the folder for the darkrpmodification-master > lua > darkrp_config > disabled_defaults.lua

Open up that lua file and under "DarkRP.disabledDefaults[“modules”] = {
[“hud”] = true, (this was false, now make it true)

Hope this helped :slight_smile:

Hello

I have the same problem. Some HUD’s are working, some not. For example is this HUD here fucked up, it only has 8 KB size
Another one is working and has 20 so in my opinion this if-line is missing in there (in the cl_hudreplacement.lua)
Can someone help me there? I also tested to put the If-line in the replacement lua file but it doesnt work