DarkRP Issue: Console/HUD & Menu dissapears

Hey all,

Been having issues recently when playing DarkRP on gmod, now note that I have been playing this back before Gmod got updated just fine but found after the update things went funny.

My HUD, including options to open console, chat and using the ‘ESC’ key to view Gmod menu goes away. I can open spawnlist and also use DarkRP’s F4 key to bring up the job menu. When I chat my character looks straight up and I can see the talk bubble over my head.

This happens at random, I don’t notice this with any particular key presses or similar, I can only fix it by Ctrl+Alt+Del crashing out and reloading up gmod.


  • Screenshots-


  • PC Specs -
    CPU: Intel i5 2500k @ 3.30Ghz
    RAM: 8GB
    GFX: NVIDIA GeForce GTX560 Ti
    GFX Driver Ver: 310.90

  • Gmod Mods/Tweaks etc -
    Wire Mod (Via Tortoise SVN)
    PHX 3 (Via Tortoise SVN)

Now what i’m about to try is:

  1. Remove PHX3 and test play
  2. Remove Wire and test play
  3. Remove all addons and test play
  4. Reinstall Gmod and start testing from clean and then each mod

I will post up a report once i’m finished with what I find, but it would be good to see if anyone else is having this issue and also as a future solution to anyone else going on a google journey.

This is not the issue where you need to disable quick wep change…

Cheers!

Ok so it seems to be either Gmod or DarkRP as I have removed all the addons.

It is a known issue with Garry’s Mod.

Well on a 28 person server, over 5 days, noone has heard or had the issue. I have reinstalled Gmod and DarkRP both via SVN and tried again on in-game download and I got the issue over and over :S

Although I notice now, sometimes, 3/5 times say, I can get console open, which then brings everything back. If I can get console, it’s a full restart or the odd chance it comes back up.

Yeah it happened to my server quite a bit but it just suddenly stopped doing it.

When you hit escape to go to the main menu, don’t hit the top option (continue or something) Hit escape again and you won’t have the problem.

Problem is, I don’t always get the option to view menu (by pushing ESC) or console, it’s almost 100% gone apart from Q menu and F4 menu for DarkRP.

However sometimes when it goes, if I hit ~ or ESC it will load console/menu and reset HUD back to normal for 10-30 minutes then it goes away again.

You should probably ask in Help & Support, not Mods & Addons
http://facepunch.com/forumdisplay.php?f=16

Ahhhhhhhhhhh no…

The description of that forum = If you’re having problems PLAYING GMod then this is the place for you.

I don’t have an issue playing Gmod, I don’t really have an issue playing DarkRP other then the HUD going away randomly. Therefore I selected the addon thread for best effect as DarkRP is a addon/gamemode.

It is still an issue with Garry’s Mod in general. I get this in sandbox. It is a known problem.

Ironically there’s also a Gamemodes section, which this still doesn’t belong in.

It goes in Help & Support.

Well I was unable to find any helpful links regarding this specific issue on here or google, there was one about missing HUD but for those threads the console was still able to be opened and thus HUD restored with a command.

However none that said console could not be used. Plus my HUD works fine with Gmod since update, been on all sorts of other gamemodes just fine, it was just DarkRP that did this, so it’s pretty obvious it’s darkrp…

As said by NightmareX91, this has nothing to do with the gamemode or addons you have installed and is a known game problem. I get this if I go to the menu via ESC and enter back to the game using ‘Resume Game’. I have had my HUD randomly dissapear on deathrun, and I can get it back by pushing ESC to open the menu and ESC to close it. There is the odd occasion where you cannot open either console or the menu, and thats when you close your game.