DARKRP Issue: Everyone spawns as Statues and has the job "Joining/Connecting"

I’ve been working on this for 4 hours now and still no luck.

Researched and found nothing that was able to help.

I haven’t modified anything inside the DarkRP gamemode, and have reinstalled it several times.

I get these (this) error when someone joins the server.

[ERROR] lua/autorun/server/sv_awarn.lua:93: attempt to call global ‘awarn_getlastwarn’ (a nil value)

  1. fn - lua/autorun/server/sv_awarn.lua:93
  2. unknown - addons/ulib/lua/ulib/shared/hook.lua:110

[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:603: attempt to index local ‘jobTable’ (a nil value)

  1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:603

[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:675: attempt to index local ‘jobTable’ (a nil value)

  1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:675

Any ideas? Thanks!

You fucked up.

Try removing your warning system.
Not to promote myself here, but I created a pretty easy warning system here: https://github.com/mrpotatofactory/WonderfulWarnings

I havent done anything to the server except install gmod and css, mount css and then launched the server (after installing the gamemodes)

Didn’t work.

Are you using the free version of AWarn2 or the paid version?

I had the exact same problem, it turns out It had something to do with this weird PlayerInitialSpawn hook I had. I still don’t know how the code triggered it but it did. It was rather annoying. Try any custom code you have with PlayerInitialSpawn

jobs.lua double check you added all commas and shit. you messed up in your jobs lua somewhere (generally the case with errors like this)

Thank you so much! This was the issue. I had changed them last night because of this error, but when I changed them back it worked. +1