DarkRP - jobTable problem.

I think I can post this in this section… this has never happened to me before, two days ago it was working fine, then in the morning DarkRP for some reason no longer worked for me. When I start up a game on Garry’s Mod in singleplayer on the DarkRP Gamemode, an error pops up and I spawn in the ground, with no job, no F4 Menu, no F3/Context. When I try and use the F4/F3 this error appears:


[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_data.lua:313: attempt to concatenate a nil value
  1. createPlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:313
   2. callback - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:407
    3. callback - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:292
     4. query - gamemodes/darkrp/gamemode/libraries/mysqlite/mysqlite.lua:302
      5. offlinePlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:258
       6. retrievePlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:303
        7. restorePlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:390
         8. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:585


[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:604: attempt to index local 'jobTable' (a nil value)
  1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:604

ServerLog: [FAdmin] Mr. No One. (STEAM_0:0:0) Spawned

[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:676: attempt to index local 'jobTable' (a nil value)
  1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:676


What I’ve done:

  • I have reinstalled DarkRP.
  • Disabled all of my addons.
  • Reinstalled Garry’s Mod.
  • Deleted some MySQL files.
  • Deleted some custom addons.
  • I’ve tried most things I’ve found online.

What I haven’t done:

  • I haven’t modified the DarkRP Core Files.