DarkRP | Nothing but jobs appearing in F4 menu?

Hey guys, so I’m currently devving a server and have run into a problem. Nothing appears in the server’s F4 menu, except for jobs. No shipments, no ammo, nada. Yes, I have tried reinstalling darkrp and the modification addon. I even went so far as to copying the modification addon onto my localhost, which ran fine with no problems, everything appearing.

Here are some of the errors I’m getting in the server console:


[ERROR] A runtime error has occurred in "addons/darkrpmodification-master/lua/darkrp_customthings/jobs.lua" on line 351.
The best help I can give you is this:

A table is being indexed by something that does not exist (table index is nil).

Hints:
e[8C- The thing between square brackets does not exist (is nil).

The responsibility for this error lies with (the authors of) one (or more) of these files:
e[8C1. addons/darkrpmodification-master/lua/darkrp_customthings/jobs.lua on line 351
e[8C2. gamemodes/darkrp/gamemode/libraries/fn.lua on line 80
e[8C3. gamemodes/darkrp/gamemode/libraries/modificationloader.lua on line 131
e[8C4. gamemodes/darkrp/gamemode/libraries/modificationloader.lua on line 142
e[8C5. gamemodes/darkrp/gamemode/init.lua on line 81
------- End of Simplerr error -------

  1. error - [C]:-1
   2. unknown - gamemodes/darkrp/gamemode/libraries/simplerr.lua:467
    3. doInclude - gamemodes/darkrp/gamemode/libraries/fn.lua:80
     4. loadCustomDarkRPItems - gamemodes/darkrp/gamemode/libraries/modificationloader.




dlopen failed trying to load:
/home/darkrp/.steam/sdk32/libsteam.so
with error:
/home/darkrp/.steam/sdk32/libsteam.so: cannot open shared object file: No such file or directory

any and all help would be greatly appreciated.

It tells you exactly what your errors are. At line 25 on resources.lua the symbol ‘`’ should not be there. At line 351 on jobs.lua “The thing between square brackets does not exist (is nil).” can you paste that code?



GAMEMODE.CivilProtection = {
	[TEAM_POLICE] = true,
	[TEAM_CHIEF] = true,
	[TEAM_MAYOR] = true,
	[TEAM_SWAT] = true,
	[TEAM_SECRET] = true,
	--[TEAM_SPECIAL] = true     (Line 351, however it is commented out)
}

updated the resources.lua, did that late one night and must’ve forgotten to edit it properly :wink:
all of the jobs listed above do exist in the jobs.lua file.

Solved, I redid some stuff and it works requesting lock.