DarkRP settings not loading upon startup. (Fadmin, etc)

So after recently restarting my server, I noticed the DarkRP settings no longer loaded. Spawns, Fadmin settings, door rights, nothing like that worked anymore.

I hadn’t installed anything new, new addons, or modified the server files, so I don’t know what could be causing it.

Here’s the only error per se that I get in the server console upon startup.



[ERROR] ...darkrp/gamemode/fadmin/playeractions/kickban/sv_init.lua:250: attempt to perform arithmetic on field 'time' (a string value)
1. fn - ...darkrp/gamemode/fadmin/playeractions/kickban/sv_init.lua:250
2. unknown - addons/ulib/lua/ulib/shared/hook.lua:183

just re instalal darkrp from svn version

Correct, and if it still occur with the standard version you should report it here:

I did, and it was fine at first, but after a while of the server running, it keeps glitching out again, blocked models list disappearing, FPP settings reset, etc.

Not even a server restart fixed it.

It also does that for custom Fadmin groups. If I make a new group called operator, set the command rights, about an hour or so later it no longer exists and people lose the rights.

Even though it’s still in the Set Access list, but when I click on it, it just says not found.

I recommend you to delete sv.db, install ULX and never touch FAdmin again (it bugs ULX)
Notice: Money will be reset.

The problem is that Fadmin is directly tied into DarkRP, I have no choice but to use it with it, as far as I know.

I’m using both Fadmin and ULX