DarkRP stuff

So I just tried to add a Radio Host career and the mic and radio show up but not the career.

Here is my code for the job:
TEAM_RADIO = AddExtraTeam(“Radio Host”, {
color = Color(20, 150, 20, 255),
model = {
“models/player/Group01/Female_01.mdl”,
“models/player/Group01/Female_02.mdl”,
“models/player/Group01/Female_03.mdl”,
“models/player/Group01/Female_04.mdl”,
“models/player/Group01/Female_06.mdl”,
“models/player/Group01/Female_07.mdl”,
“models/player/group01/male_01.mdl”,
“models/player/Group01/Male_02.mdl”,
“models/player/Group01/male_03.mdl”,
“models/player/Group01/Male_04.mdl”,
“models/player/Group01/Male_05.mdl”,
“models/player/Group01/Male_06.mdl”,
“models/player/Group01/Male_07.mdl”,
“models/player/Group01/Male_08.mdl”,
“models/player/Group01/Male_09.mdl”
},
description = [[Broadcast.]],
weapons = {},
command = “radiohost”,
max = 1,
salary = 70,
admin = 0,
vote = false,
hasLicense = false,
customCheck = function(ply)
return ply:IsUserGroup(“user”)
end
})

AddEntity(“Microphone”, “radio_microphone”, “models/mic.mdl”, 500, 2, “/buymicrophone”, nil, function(ply) return ply:GetNWString(“usergroup”) == “user” end)

Any idea why it wouldn’t be showing up?

But not the career??

Yea, like when you press f4 there is no radio host job

No lua errors?

Couldn’t include file ‘includes\modules\voicechannel.lua’ (File not found) (@addons/voiceradio/lua/autorun/radio_init.lua (line 20))

[ERROR] addons/voiceradio/lua/autorun/radio_init.lua:20: Module not found!

  1. require - [C]:-1
  2. unknown - addons/voiceradio/lua/autorun/radio_init.lua:20

[ERROR] addons/darkrpmodification-master/lua/darkrp_customthings/shipments.lua:19: ‘}’ expected near ‘)’

  1. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/shipments.lua:0

[ERROR] addons/darkrpmodification-master/lua/darkrp_customthings/doorgroups.lua:12: unexpected symbol near ‘)’

  1. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/doorgroups.lua:0

Forgot about that lol

Post the lines around line 19 in shipments.lua, then you can post doorgroups aswell.

But those lua errors shouldn’t prevent the job from appearing in F4.

Shipments

Add shipments and guns under the following line:
---------------------------------------------------------------------------*/
AddCustomShipment(“Alcohol”, “models/drug_mod/alcohol_can.mdl”, “durgz_alcohol”, 1000, 10, false, nil, false, {TEAM_DRUG})
AddCustomShipment(“Aspirin”, “models/jaanus/aspbtl.mdl”, “durgz_aspirin”, 3000, 10, false, nil, false, {TEAM_DRUG})
AddCustomShipment(“Cigarettes”, “models/boxopencigshib.mdl”, “durgz_cigarette”, 500, 10, false, nil, false, {TEAM_DRUG})
AddCustomShipment(“LSD”, “models/smile/smile.mdl”, “durgz_lsd”, 700, 10, false, nil, false, {TEAM_DRUG))
AddCustomShipment(“Heroin”, “models/katharsmodels/syringe_out/syringe_out.mdl”, “durgz_heroine”, 6000, 10, false, nil, false, {TEAM_DRUG})
AddCustomShipment(“Marijuana”, “models/katharsmodels/contraband/zak_wiet/zak_wiet.mdl”, “durgz_weed”, 5000, 10, false, nil, false, {TEAM_DRUG})
AddCustomShipment(“Water”, “models/drug_mod/the_bottle_of_water.mdl”, “durgz_water”, 100, 10, false, nil, false, {TEAM_DRUG})

AddCustomShipment(“LSD”, “models/smile/smile.mdl”, “durgz_lsd”, 700, 10, false, nil, false, {TEAM_DRUG})

but they have nothing to do with your jobs not appearing.

Weird. I wonder whats wrong then. :confused:

Why are you making sure the user is in the group “user”?

Could it be possible that as you are the owner and you aren’t in the user group the job may not appear for you? Although I would imagine anything above user would be able to see it but it’s worth a shot of just removing the whole customcheck and check if you can see it.

Okay, I’ll try and let you know!

[editline]14th October 2013[/editline]

Okay so I just tried that and it just makes all the custom jobs that ive added disappear