DarkRP Weapon Problem.

Dear people of facepunch,

My darkRP server has been experiencing issues with weapons.
I have tried searching for all sorts of solutions, but none of them appear to work.
If i try to spawn weapons it says ‘Sorry, you cannot use this!’ or if before i restricted F4 /buy for weapons
i tried to buy one it would take my money and put the pistol on the floor, yet i would not be able to pick it up.
Jobs also, do not spawn with the desired weapons. Such as CP: You do not spawn with stunstick, arrest, unarrest,
handgun, door_ram etc. I have reinstalled CSS several times, contacted the server host. No clue there either.

Please suggest some solutions,

Thank you.

Sounds like you just deactivated weapons. There’s a command for it in the list.

the Admin tab on F4 menu? Is it supposed to be ticked or unticked?

Do you have a gun license?

If you can’t pick the weapon up, your CS:S content isn’t being installed correctly.
Also make sure rp_license is set to 0.
If you still have issues, please keep us updated and I’ll look into this some more.

I’ve got the same issue as him. I’m running ULX+ULIB and DarkRP. Upon trying to spawn weapons using the Q Weapons tab menu it says “You cannot do this!”

And classes are not spawning with guns. :frowning: