DarkRPHud Errors ?? Help

I keep getting these weird errors that have to do with Darkrphud 1-5

this is what shows when i open my chat >>

[ERROR] lua/includes/modules/draw.lua:243: ‘DarkRPHUD1’ isn’t a valid font

  1. SetFont - [C]:-1
  2. WordBox - lua/includes/modules/draw.lua:243
  3. fn - gamemodes/darkrp/gamemode/modules/chat/cl_chatlisteners.lua:62
  4. unknown - addons/ulib/lua/ulib/shared/hook.lua:183

How about you just read your original thread and not make a new one?

No im sorry that thread was for a dif post so i made a new one so it was on this object.
im sorry if it looks like im double posting

I am positive this is the same issue as the last thread…

well actually the last one was for the see through map which was caused by 3D Car dealer
But im sorry

It’s okay to post 2 happenings in one thread. You’ll just get a lot of hate for making two under the same timeframe.

Now i get this>>

[ERROR] gamemodes/darkrp/gamemode/modules/base/sh_createitems.lua:517: attempt t
o call field ‘getAvailableVehicles’ (a nil value)

  1. AddCustomVehicle - gamemodes/darkrp/gamemode/modules/base/sh_createitems.lu
    a:517
  2. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/vehicle
    s.lua:13
    3. include - [C]:-1
    4. loadCustomDarkRPItems - gamemodes/darkrp/gamemode/libraries/modification
    loader.lua:111
    5. fn - gamemodes/darkrp/gamemode/libraries/modificationloader.lua:119
    6. unknown - addons/ulib/lua/ulib/shared/hook.lua:183

2. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/vehicle
s.lua:13

? i looked at line 13 nothing wrong

Just post a few lines surrounding that line and let us take a look :wink:

Since you are talking about lua, what does this mean? —


3. include - [C]:-1

This is whats near it >>


Error! Variable "$envmapcontrast" is multiply defined in material "katharsmodels
/syringe_out/syringe_body"!

[ERROR] gamemodes/darkrp/gamemode/modules/base/sh_createitems.lua:517: attempt t
o call field 'getAvailableVehicles' (a nil value)
  1. AddCustomVehicle - gamemodes/darkrp/gamemode/modules/base/sh_createitems.lu
a:517
   2. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/vehicle
s.lua:13
    3. include - [C]:-1
     4. loadCustomDarkRPItems - gamemodes/darkrp/gamemode/libraries/modification
loader.lua:111
      5. fn - gamemodes/darkrp/gamemode/libraries/modificationloader.lua:119
       6. unknown - addons/ulib/lua/ulib/shared/hook.lua:183

Executing dedicated server config file server.cfg
Using map cycle file 'cfg/mapcycle_default.txt'.  ('cfg/mapcycle.txt' was not fo
und.)

Not that. He’s talking about what’s near line 13 in the code?

o ok

[editline]12th July 2014[/editline]


/*---------------------------------------------------------------------------
/*---------------------------------------------------------------------------
DarkRP custom vehicles
---------------------------------------------------------------------------

This file contains your custom vehicles.
This file should also contain vehicles from DarkRP that you edited.

For examples and explanation please visit this wiki page:
http://wiki.darkrp.com/index.php/DarkRP:Vehicles


Add vehicles under the following line:
---------------------------------------------------------------------------*/
--Streetracer
AddCustomVehicle("ferrarif1", "models/sentry/ferrarif1.mdl",50000, {TEAM_STREETRACER})
--Taxi
AddCustomVehicle("crownvic_taxitdm", "models/tdmcars/crownvic_taxi.mdl", 20000, {TEAM_TAXIDRIVER})
--Police
AddCustomVehicle("sgmcrownviccvpi", "models/sentry/07crownvic.mdl", 10000, {TEAM_POLICE})
--Ambulance
AddCustomVehicle("c5500ambulance", "models/sentry/c5500_ambu.mdll", 10000, {TEAM_MEDIC})
--Civ Cars

Do all those car entities actually exist and are those the exact class names?

Yes to all

Obviously, the error doesn’t think so. Can you temporarily comment out all of the AddCustomVehicle lines and see if the error is fixed?

well that worked but i need these vehicles and they used to work so now what?

[editline]12th July 2014[/editline]

none of them work at all

That means one or more of your vehicle classes are invalid.

all of them are and i dont know why they used to work?