DDOS ATTACK on my server !!! [HELP PLZ !!]

Hello guys! i have a big problem on my server… someone is DDOS Attacking my server!

Sometimes, everyone start lagging, and players can’t move… like the server has crashed

And the ping of everyone increase!

I think someone have a booter, and he is ddosing my server…

How can i fix that? please

Based off of your thread here: http://forum.facepunch.com/showthread.php?t=1405070

I’m getting the impression that people wouldnt like you very much… To fix the problem, if I were you I would stop trolling and not piss people off.

There are various means of DDoS protection; just google.

It would help to monitor incoming packets (if you can) and find what type of DDoS it is.

I have this in the console of my server, would that cause the ddos??

CreateFragmentsFromFile: ‘user_custom/11/1148cd00.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/79/798cf6a5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/f0/f075d4e4.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/b0/b09f6269.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/4d/4d707711.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/79/79a357d9.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/71/714fcaf6.dat’ doesn’t exist.
Model missing: models/captainbigbutt/vocaloid/neru.mdl
Model missing: models/player/dokuro_chan_pm.mdl
[RpZ.BlackBirdy|507|STEAM_0:0:16242102] Lua Error:

[ERROR] lua/weapons/weapon_popcorn/cl_init.lua:39: Tried to use a NULL entity!

  1. LookupAttachment - [C]:-1
  2. func - lua/weapons/weapon_popcorn/cl_init.lua:39
    3. unknown - lua/includes/modules/net.lua:30

[RpZ.BlackBirdy|507|STEAM_0:0:16242102] Lua Error:

[ERROR] lua/weapons/weapon_popcorn/cl_init.lua:39: Tried to use a NULL entity!

  1. LookupAttachment - [C]:-1
  2. func - lua/weapons/weapon_popcorn/cl_init.lua:39
    3. unknown - lua/includes/modules/net.lua:30

Client “Mr.Blöd” connected (91.48.152.97:27005).
CreateFragmentsFromFile: ‘user_custom/11/1148cd00.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/79/798cf6a5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/f0/f075d4e4.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/87/87c0fec7.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/b0/b09f6269.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/64/645824ca.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/4d/4d707711.dat’ doesn’t exist.

[editline]29th June 2014[/editline]

Model missing: models/player/dokuro_chan_pm.mdl
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.
CreateFragmentsFromFile: ‘user_custom/c9/c99c06d5.dat’ doesn’t exist.

Can you please not use a leaked version of my chatbox

No… Those are issues on your part

I know those Fragments errors look strange, but they’re just spray related if I recall and not very useful in finding your problem

And usually are solved by server restart AFAIK.

The prints will happen if you’ve disabled sv_allowupload but not sv_allowdownload. It’s hardly an issue though.

Fragment errors are created when either download or upload is off (I forget which one), so the user can’t send sprays.

The errors probably happen since the ddos isn’t really letting the joining players upload their spray to the server.

I have the sv_allowupload set to 0 and sv_allowdownload set to 1

[editline]29th June 2014[/editline]

i bought it on coderhire -___-’

He has a list of steam users who has purchased his chatbox, and he’s probably just checked and seen you’re not on it. You’re not fooling anybody.

Think about it. If you’re the type of person who buys stuff off of coderhire (probably doesn’t even buy it, uses leaked content), don’t you see why you’d be ddos’d?

Okay besides the fact this guy is a moron, thief and a dick.

He is not being DdoS’d, facts:

  1. it’s only occasional - why would the attacker stop and start? Sounds like our faggot here has no protection though so even a small attack would crash it all
  2. DDoS + no protection =/= lag… If it’s an actual boot, then you’re crashing and not coming back not tot mention you’ll get null routed after a bit by your host or ISP.

Oh, is this server being rented or are your hosting it on your own PC?