Dead Air - 4th map ported to Garry's Mod.

[release]The 4th level of L4D’s Scenario “Dead Air” is finally available to download… for Gmod !

[ul]How to get it working ?


NEW EASIER AND FASTER METHOD HERE!
http://www.facepunch.com/showthread.php?t=903768

[/ul]

[ul]Step 1 : Getting the L4D models and materials to Gmod
-Download and launch Gibbed’s .VPK Extractor.
-Click on “Extract” and browse to your Left 4 Dead folder (steamapps/common/left 4 dead/left4dead)
-Select “pak01_dir.vpk”
-Now, select the folder you want the files to get extracted in. I’d suggest you to make a new folder.
-Click on OK and wait for it to finish.

When it’s done, browse to the folder in wich you extracted the files. You should see a models folder, open it.

-Download this .bat file, it will fix the files so they work in the Source Engine 14 (Garry’s Mod Engine)
-Put it in the models folder and launch it.


-If the bat file open notepad instead of a cmd : just open it with notepad, "Save As" and rename it "vtxfixer.bat" (Thanks GoldenBullet)

-Wait for the .bat to fix the files.
-When it’s done, just put the Models, Materials and Sound files to your Garrysmod folder.
-???
-PROFIT![/ul]

[ul]Possible other way to get the models and textures
Download this pack : http://www.facepunch.com/showthread.php?t=773145


I don't know if it will work, when i tried it failed, but worked for jason278. Please send a feedback about this method in the thread!

[/ul]

[ul]Step 2 : Fixing known bugs

-Shiny zombies : Download the garrysmod.org zombie pack, or just fix the .vmt by yourself. (i’m not going to explain how, either you know how to do it, or you don’t, and it may fuck up everything)

-Wireframe ropes : delete the “cable” folder in garrysmod/materials

-Visible area_portals : I forgot to delete some of them, since the compiling takes waaaaaaay too long, you’re going to have to hide them by yourself.[/ul]


*DOWNLOAD*

http://www.garrysmod.org/img/?t=dll&id=75482

http://uppix.net/5/e/5/8005b7f95b0aedfddd9a7e29eef50t.jpg http://uppix.net/0/3/5/80c1a67db7ebfd4793367ba18ed8et.jpg http://uppix.net/4/d/3/a7e105466ea2935e1525ffdab2bfat.jpg http://uppix.net/1/9/4/1b463eeda6ed6cf8a5144861a64c5t.jpg

Video by itzapy!

[/release]

Have fun with it, i may port more if i have the motivation and time.
Also, don’t forget to thanks BigBoom, i couldn’t have released it without his help !

ohhh shiiiii…

So, where can I meet up and have sex with you? :smiley:

Pau, France, a street named “LaCroix”
I am waiting for you. :3

Cool! What I like the most about the port is the van actually works, although I still have to extract the sound.

Also the only thing I’ve got wrong about the map is that I see white wires hanging from the walls.

Read the Step 2 : Fixing known bugs.
“-Wireframe ropes : delete the “cable” folder in garrysmod/materials”

Plz NO MERCY~

first level of no mercy could be made into rp if u made daylight and fixed the apartments and shops

HOLY SHITA! Awesome work indeed. Now I just gotta wait for the fucking L4D model pack finishes installing

Holy fucking dog shit!

Not going to release a No Mercy map in a while. Do not ask me why.
For now i’ll focus on Dead Air and Death Toll.

I extracted all the files, and put the .bat file in the models folder, but you said “run it”. What do I run? L4d?

Run vtxfixer.bat.

its just a text file for me…im not opening it in notepad, is there a way to run it normally?

Weird, it should open a cmd.
So, try this :
-Open a new cmd windows. (search “cmd” on vista, or execute “cmd” on XP)
-When it’s open, select the drive the models are in by typing this : “E:” (change “E” to your drive letter)
Press ENTER

  • Now, get on the models folder by typing this : “cd folderdirectory”. Example : “cd Program Files\steam\l4dmodels\models”
    Press ENTER

  • Now, open the cmd by typing this : “open vtxfixer.bat”

Well, it all worked up until the VERY last step. When i type “open vtxfixer.bat”, I get a message that says ““open” is not recognized as an external or internal command, operable program or batch file”

I’ve tried “run”, too, same thing…

Use “start” instead of “open” then.

well, now it says it can’t find the file…I checked the path, and the file name…I feel extremely stupid

“start vtxfixer.bat”
If it doesn’t work, then “start vtxfixer”

“Windows cannot find ‘vtxfixer’. Make sure you typed the name correctly and try again.” I’ve tried both file names (vtxfixer and vtxfixer.bat) would it matter if I changed the name of the .bat file and try ti run it, or does the name matter.

EDIT:

Well, It doesn’t look like that worked…im gonna check the path again…

EDIT: maybe I have a corrupt file or something, it doesnt work…