Debugging Maps

I’ve had this problem before, but whenever I make long term changes to a map, constantly saving, and I run it with no issue to be apparent in the Compile Process Window, it crashes my game when the map is said to be ran. Now I’ve tried to look at the crash log, uploaded to GDump, here is my crash log, and here is my Compile Process Window, but still no luck. If anyone can help me debug map issues, I would really appreciate it.


material not found!: gm_construct/water

error: material gm_construct/water doesn't have a $bottommaterial

From your compile log. Those shouldn’t be causing a crash though.

I’m no expert, but maybe this has something to do with it?

Should be ok up to 300% i believe.

There is no limit on EntData, I made a short post about it here. Valve don’t recommend you go over 100%, but you can. I had a map with bout 300% entdata at compile time and it worked fine in MP and SP; this map was also procedurally generated and started off with 2000 ents (Representing that 300%) and finished on 6000 ents during run time - again with no issues.

http://forum.facepunch.com/showthread.php?t=1284014&p=41267368&viewfull=1#post41267368

There’s nothing obvious in that compile log that looks alarming, but it may be worth removing that gm_construct/water material just to eliminate that.

Give this is a downtown map, did you decompile it from another map? It’s possible that something got screwed up during the de-compile process. The compile process will normally pick most errors with the map up, but not all!

If none of the above, then it’s going to be cordon off each bit of the map until it stops crashing.