Dedicated Linux Server Help

Hello guys!

When I try to run my server, I get this/these errors:



root@icsource:~/bin/server_1# ./srcds_run -game garrysmod +maxplayers 12 +map cs_office -debug -ip 123.xxx.xx.xxx


************** WARNING ***************
Running the dedicated server as root
is highly discouraged. It is generally
unnecessary to use root privileges to
execute the dedicated server.
**************************************


Auto detecting CPUntinue to launch in 1 secondss
Using default binary: ./srcds_linux
Enabling debug mode
Server will auto-restart if there is a crash.

Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
/root/.steam/sdk32/libsteam.so
with error:
/root/.steam/sdk32/libsteam.so: cannot open shared object file: No such file or directory
Logging into anonymous gameserver account.
Fetching Workshop Addons.. No -authkey
dlopen failed trying to load:
/root/.steam/sdk32/libsteam.so
with error:
/root/.steam/sdk32/libsteam.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
/root/.steam/sdk32/libsteam.so
with error:
/root/.steam/sdk32/libsteam.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
/root/.steam/sdk32/libsteam.so
with error:
/root/.steam/sdk32/libsteam.so: cannot open shared object file: No such file or directory
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Network: IP 123.xxx.xx.xxx, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
PREP OK
Segmentation fault (core dumped)
cat: hlds.1893.pid: No such file or directory
email debug.log to linux@valvesoftware.com
Sun Jun 22 14:40:50 EDT 2014: Server restart in 10 seconds
Sun Jun 22 14:40:53 EDT 2014: Server Quit

root@icsource:~/bin/server_1#


I’m running Ubuntu 13.10 64-bit

Please help!
If I happen to resolve without help of this lovely forum, I’ll post my resolution!

[editline]22nd June 2014[/editline]

Okay,
I managed to get something fixed:



root@icsource:~/bin/server_1# ./srcds_run -game garrysmod +maxplayers 12 +map cs_office -debug -ip 123.xxx.xx.xxx


************** WARNING ***************
Running the dedicated server as root
is highly discouraged. It is generally
unnecessary to use root privileges to
execute the dedicated server.
**************************************


Auto detecting CPUntinue to launch in 1 secondss
Using default binary: ./srcds_linux
Enabling debug mode
Server will auto-restart if there is a crash.

Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Logging into anonymous gameserver account.
Fetching Workshop Addons.. No -authkey
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Network: IP 123.xxx.xx.xxx, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
PREP OK
Segmentation fault (core dumped)
cat: hlds.2155.pid: No such file or directory
email debug.log to linux@valvesoftware.com
Sun Jun 22 15:04:21 EDT 2014: Server restart in 10 seconds
Sun Jun 22 15:04:23 EDT 2014: Server Quit

root@icsource:~/bin/server_1#


You seem to be missing files, verify files on your server