Dedicated Server Fails to start (Load From File Failed resource/serverevents.res)

I’ve tried to create a Garry’s Mod dedicated server, but it’s crashing with an engine error.

The startup script I’ve used to download, install, and run the server is this:


@title Starting Garry's Mod Server
@cd C:\Users\REDACTED\Games\steamcmd\
@steamcmd +login anonymous +force_install_dir C:\Users\REDACTED\Games\garrys-mod\bin +app_update 4020 validate +quit
@cd C:\Users\REDACTED\Games\garrys-mod\bin
@start /wait srcds.exe -console -game garrysmod +maxplayers 4 +map gm_construct

EDIT: The REDACTED portion of the path does not contain spaces; otherwise the entire path would be surrounded with “double quotes”. I’ve read and watched a multitude of guides on how to set up a server, and I’ve searched near and far for answers from others who have had the problem, but I haven’t found a single solution that’s not “validate the game”, which I’ve done (the validate is part of the startup script, and I’ve run it many times). I even did a re-install, to no avail.

For the uninitiated, this is the equivalent to opening SteamCMD and running:


Steam>login anonymous
Steam>force_install_dir C:\Users\REDACTED\Games\garrys-mod\bin
Steam>app_update 4020 validate
Steam>quit

This is the output for Garry’s Mod once it start up:



Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game.dll loaded for "Garry's Mod"
---------------
Paths:
--- ENGINECORE ---
"c:\users\REDACTED\games\garrys-mod\bin\" "EXECUTABLE_PATH"
"c:\users\REDACTED\games\garrys-mod\" "BASE_PATH"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\bin\" "GAMEBIN"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "LOGDIR"
--- GMODCORE ---
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\workshop\" "GAME"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\workshop\" "workshop"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\workshop\" "thirdparty"
"C:\Users\REDACTED\Games\garrys-mod\bin\garrysmod\garrysmod.vpk" "MOD" (VPK)
"C:\Users\REDACTED\Games\garrys-mod\bin\garrysmod\garrysmod.vpk" "GAME" (VPK)
"C:\Users\REDACTED\Games\garrys-mod\bin\garrysmod\garrysmod.vpk" "garrysmod" (VPK)
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "MOD"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "MOD_WRITE"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "DEFAULT_WRITE_PATH"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "GAME"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "GAME_WRITE"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\" "garrysmod"
--- SOURCESDK ---
"c:\users\REDACTED\games\garrys-mod\sourceengine\" "GAME"
"c:\users\REDACTED\games\garrys-mod\platform\" "GAME"
--- DOWNLOADS ---
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\download\" "GAME"
"c:\users\REDACTED\games\garrys-mod\bin\garrysmod\download\" "DOWNLOAD"
--- FALLBACKS ---
"C:\Users\REDACTED\Games\garrys-mod\bin\garrysmod\fallbacks.vpk" "GAME" (VPK)
LOAD FROM FILE FAILED resource/serverevents.res


Screenshots:

The error

http://puu.sh/wh3Ma/e9d4137d01.png

The SteamCMD output window

http://puu.sh/wgYun/58c6d585c6.png

EDIT 2: The crashes do generate .mdump files, but I have refrained from posting them in case they contain sensitive information.

I’m just trying to set up my first server as well, and therefore I can’t really help you with the specifics, but I found this guide on steam:https://steamcommunity.com/sharedfiles/filedetails/?id=179569412

I followed it and the server starts at least. Used this for the initial server.cfg as well: http://gmodcfgmaker.com/

This output isn’t part of the normal startup process. Considering how early it appears, it is likely that an incorrect dll is being loaded. Posting an .mdmp will help diagnose the problem if this is the case.

If you are worried about “sensitive” information being in the dump, just install your dedicated server to a folder that isn’t in your windows user folder. For example, all of my SteamCMD stuff is in ‘D:\SteamCMD’.

I’m not very familiar with Linux but why are you validating your Garry’s Mod files every time you launch? When I had my Linux server it was a case of running the server from a new screen every-time it needed a restart/launch. If you’ve tried just running it plain and simple without launching SteamCMD before hand, ignore me.


/home/ttt/gmod/srcds_run -game garrysmod +gamemode >>further params