Dedicated server issue

I’ve had a dedicated server that worked for 3 months but suddenly stopped working. It happened while it was running. Based on ULX logs, it looks like it was last working 9/18/13 at 1:16 AM (The last player on left at that time.)

The issue is that it only works as a LAN; the ip displays as the external ip for others, on port 27016. No one can connect to it. I can only connect to it by typing the internal IP, which for me displays as the internal IP in the game info.

Some background:

-The port has always been 27016; for some reason, 27015 wouldn’t work when setting it up.
-It’s on another computer on my local network
-Hosting it on this computer and the other one worked fine for both.
-I was able to connect from this one to the other, or this one to this one.
-Connecting from this one to the other one worked, but randomly, when I spawned props on the server, everyone’s ping except mine would shoot up to 996 and they would get horrible lag. A restart fixed it when it happened. I connected using the external IP.
-The two computers are connected to a powerline switch which is connected to the router
-The service is at&t U-verse
-DHCP is on, but IP addresses never change.

The issue now:

-I’m unaware of any changes that may have happened to the router. Forwarding for other game servers still works fine.
-There was no change done to the computer when it stopped working.
-It doesn’t work when hosted from this computer either.
-It’s a LAN now; when connecting to it, the internal ip shows in the console instead of the external like normal.
-I’ve tried with a completely clean installation of garry’s mod.
-I had the minimum number of ports needed open originally; shooting it up to 27005-27050 for TCP and UDP still doesn’t help.
-Changing back to 27015 doesn’t help.
-I’ve tried removing the workshop installation command from the server script.
-Other game servers hosted on both computers work fine.
-Other people typing connect [external ip]:port doesn’t work.
-I’ve tried sv_lan 0
-I’ve tried updating the garrysmod server installation
-There aren’t any other devices on the network forwarded with the same ports.

Server console at startup:


Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game.dll loaded for "Garry's Mod"
Initializing Steam libraries for secure Internet server
Steam_: BugslayerUtil.DLL not found
Logging into anonymous gameserver account.
Fetching Workshop Addons.. No -authkey
Network: IP 192.168.1.71, mode MP, dedicated Yes, ports 27016 SV / 27005 CL
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
PREP OK
Lua JIT is DISABLED!
Executing dedicated server config file server.cfg
Map cycle file 'cfg/mapcycle.txt' was not found
Nav File is wrong or something (1)
Initializing Steam libraries for secure Internet server
Logging into anonymous gameserver account.
Connection to Steam servers successful.
   Public IP is [external IP here].
Assigned anonymous gameserver Steam ID [Too lazy to type this].
VAC secure mode is activated.


Startup script:



cd C:\srcds\games\
srcds.exe -console -game garrysmod +gamemode spacebuild +map gm_new_worlds -maxplayers 16 -port 27016


I’m not looking for criticism on my setup and extreme ignorance about computer networking. I’m looking for a solution to the immediate problem.

Thanks

DHCP opens all ports to a specific LAN machine, so you should disable that and just forward the ports you need.

I’ve stumbled upon a few fellas that have issues with AT&T and it seems to me that AT&T has blocked port 27015. This might not be your issue but it’s worth a shot; append your port range to 27215 instead of 27016 and add 27215 to the cmd params.

Not really sure what you mean here. I didn’t think that’s what DHCP does… I see “DMZplus” in the configuration for each device (which is of course not enabled for any devices.) Is that what you meant?:

Originally I didn’t have the range at 27005-27016, I had 27005 and 27015-27016.
But anyway, I tried using 27215 and it still didn’t work, even after I tried forwarding not just that, but all 27005-27215 (yes i changed it to -port 27215 in cmd.)

EDIT: I left the server running on 27215 and someone joined… The internal IP is required to connect, which works with both ports. And why exactly could I previously connect to my own server with the external IP, but not now?
EDIT2: canyouseeme.org can see through 27015 and 27016 but not 27215 unforwarded. I still cannot connect using external ip. Kind of odd. Other people can connect with the old ports now… problem solved