Dedicated server problem - gamemode errors and Q menu issues

A few friends of mine bought and set up a dedicated server to run a few Garrysmod servers, basically, a build, spacebuild, RP, and a private server. We have already set up one dedi in the past, and no issues with getting them to work. This is the first time we have had this issue.

On all of the servers that they installed Garrysmod, and the essential addons (PHX, ULX, etc), they received identical errors.

Upon joining the server, my friends immediately received errors in the top right:


: ERROR: GAMEMODE:'HUDPaint' Failed: sandbox/gamemode/cl_init.lua:74: attempt to call method 'PaintNotes' (a nil value)

And they were not able to open the Q menu, and sometimes, not even the main menu. And upon switching to the toolgun, which in-game is called “Scripted Weapon”, and one of my friends who switched got this error:


: wire/client/toolscreen.lua:21: attempt to index global 'gmod_toolmode' (a nil value)

There are no addons on the server at all.

Upon me joining, I didn’t have this issue. I had no errors in my console, except for ULX help spam. I then joined something other than build (which was set to sandbox), like the spacebuild server, and had the same result.
On joining the RP server however, I had all of the errors mentioned above.

We cleared out the entire server from addons, and non essential lua and tried again. To no avail, the errors remained. We reinstalled the entire server, from scratch, and had the same problem.

We then deleted the gamemode folder, put -verify_all in the startup bat, and then ran the updater. After that, we tried again. The same issue occured.

This might be something that we’re downloading from the srcds servers, I’m not sure, but our Dedi is on hold until we can fix this problem.

I did some checking up, and a few people had the same issues:

http://www.facepunch.com/showthread.php?t=892877

Does anybody have any information pertaining to fixing this issue? Or is this a fix that needs to be released?

Much thanks for anybody that can help. I’ll post instructions when we’ve fixed the server in case people are having the same issue.

it might be A addon that your friends have or its just basicly the gamemode…

No, its nothing to do with the clients addons. We’ve already singled that out after one of my friends cleared out and reinstalled his Garrysmod, and tried joining. The same error occurred.

We tried uploading our own gamemodes, ones we know work, and put them on the server. Made no change.

FlapJack posted a fix in the second of the three links you gave us. Use that?

We used that too. All it did was hide the error, and keep it from showing. It didn’t fix the problem unfortunately.

Still having the issue, we’ve tried a total reinstall. Our TF2 servers are working perfectly, except for our Garrysmod servers. None of them load the proper gamemode, and while sv_gamemode in the console will bring up the proper name, something is wrong with the core sandbox gamemode.