Dedicated Server - "Server Not Responding"

I’m trying to set up a server so my friend and I can set our own rules and build without anyone else.

I followed this guide:

and I was able to set up a server that works for me but my friends says it always says “Server Not Responding” when he tries to join.

My router has a weird port forwarding page that doesn’t allow you to set the inbound and outbound server so I only forwarded port 27015 (UDP & TCP) and 26901 (UDP). My friend and I can see my server in the Internet tab of Gmod so I think port 26901 is forwarding properly but I’m not sure about port 27015.

This is the guide for port forwarding on my router:

Something that I noticed is that when I use the PFPortChecker software to check port 27015 it says that it is open but when I check on this page:
http://cpfx.ca/srcds/portcheck.php

both of the tests fail for port 27015.

Can anyone help?

This has been extremely frustrating.

Here’s an update:

I read that the outgoing port does not have to be set when port forwarding on my router so I forwarded all of the incoming ports and my friends was finally able to join the server and we played for a few hours on Gmod. I was happy until we tried to play again and I turned on the server software and my friend wasn’t able to join again… He said he was getting the “Server Not Responding” message again.

I checked to make sure the ports were still forwarded and I reinstalled the server software but it’s still not working.

Do you guys know of anything else I could try to get the server working again?

Did you open the port in the firewall?

I didn’t have the ports open in the firewall when we were able to play last Friday but I did open the ports in the Kaspersky firewall yesterday but my friend still wasn’t able to join.

Might be DHCP.
If you haven’t, set your IP to a static address.

If DHCP is on, your IP changes every time you restart your computer, invalidating the port forwards.

I don’t think that’s the problem either because my local IP (the one I used to set the port forwarding) never changes.

Bump

Any more ideas? :confused:

I really need to get a server set up.

Sorry for the bumps but I took some screenshots today that might help you guys troubleshoot the problem.

Local IP (for port forwarding)

https://lh6.googleusercontent.com/-qy3xNkFBL6k/TemOB8rlJRI/AAAAAAAAAHs/xpNd6VZl5Fo/ipconfig.png

Router port forwarding setup

https://lh4.googleusercontent.com/-CBWZwopKP7c/TemOC-KnQfI/AAAAAAAAAHw/FFdTAH8ru00/s640/ports.png

This is the server output:

https://lh6.googleusercontent.com/-eyPb6YNXj3Q/TemVTiyulRI/AAAAAAAAAH4/jjT8CW2K0rE/s512/CMD.png

server.cfg


//Basic settings
"hostname"                "NC Server"
"rcon_password"                 "" //Remote control password
"sv_password"                 ""  //Server password
"sv_region"                     "255" // eastcoast: 0 - westcoast: 1 - south america: 2 - europe: 3 - asia: 4 - australia: 5 - middle east: 6 - africa: 7 - world: 255
"sv_lan"                    "0"  //Lan only (1) or no (0)

// Sandbox server settings
"sbox_godmode"                "0"
"sbox_plpldamage"            "0"  // set this to 1 to disable player vs player damage.
"sbox_noclip"                "1"

// Sandbox limits
"sbox_maxprops"                "150"
"sbox_maxragdolls"            "2"
"sbox_maxnpcs"                "0"
"sbox_maxballoons"            "10"
"sbox_maxeffects"            "10"
"sbox_maxdynamite"            "1"
"sbox_maxlamps"                "20"
"sbox_maxthrusters"            "20"
"sbox_maxwheels"            "10"
"sbox_maxhoverballs"            "10"
"sbox_maxvehicles"            "3"
"sbox_maxbuttons"            "20"
"sbox_maxemitters"            "5"
"sbox_maxspawners"            "3"
"sbox_maxturrets"            "2"

Can anyone see any reason why my server wouldn’t be allowing my friend in?