DFrame / Derma Error - (a nil value)

Hello all.

I have tried to debug a simple window without any success.

Getting:

In the console.

Using this simple one:


local DermaPanel = vgui.Create( "DFrame" ) 
DermaPanel:SetPos( 100, 100 )               
DermaPanel:SetSize( 300, 200 )             
DermaPanel:SetTitle( "My new Derma frame" )
DermaPanel:SetVisible( true )               
DermaPanel:SetDraggable( true )             
DermaPanel:ShowCloseButton( true )        
DermaPanel:MakePopup()

Using cmd:


lua_openscript mylua.lua

Is the Derma panel not compatibility with gmod 13 or did I just make a dumb misstake?

Thanks In Advance.

Run it clientside.

How do I run it clientside?


lua_openscript_cl mylua.lua

Just a slight note.

You may want to learn what the difference between shared, clientside, and serverside.

Yeah I know the diffence but when I try to run it as “lua_openscript_cl” nothing happends.

I tried to set the lua file both in lua folder and autorun>client. No reaction in console. (not even auto-popup the name of the lua file like it does in “lua_openscript)”.

Type sv_allowcslua 1 in console first.

Just put a file in lua/autorun/client then add the derma to a console command. Then just run the console command and it’ll pop up.

Thank you now its working.