Different class tables on any server

Okay, so today I wanted to join my server, appearently i got the error: “Server has different class tables”. Cool, I ran an update on both my PC and my server (A VPS running Gentoo). Apearently there was no new updates for either the server nor the client version of the game. I tried to join a couple of other servers, and experienced the same error on all of them.
I went out of the game and validated the cache files, they were validated successfully. Then i remembered a tip from steam, when i had a problem like this with CS: Source, so i deleted the cache folder and joined the game again. Now it began redownloading all the cache files and I got the same error when it was done. Now I am totally blank of what to do?

What I’ve tried:

  • Restarting Steam
  • Updating server
  • Validating server files
  • Validating game cache files on client
  • Redownloading game cache files on client

I’m running Windows 7 x86_64 on my PC, but everyone else I know are able to connect to my, and others, servers.

Rather odd. Try renaming clientregistry.blob

Normally this is just a update error. Maybe for whatever reason the update is not registering for you. Try manually getting the update and installing it.

And where is this file exactly? Can’t find it?

@JuiceHead3311
Well, I remember myself downloading the update last wednesday?
After a quick google I can’t even find a way to manually update the game.

Hmm, that sounds right, I guess try a reinstall if you don’t get a solution soon.

It’s in the Steam root folder.

Renaming the clientregistry.blob didn’t help…

You need to restart Steam after doing it.

I did, or well, it wasn’t started from the beginning. I usually close programs before editing their files.

Bump

Appearently the problem is serverside. Reinstalling the game data does not help either.
Additionally all of my friends had to download a lot of dua files from my server before “joining”.