DirectX 8/9 Problem

Hi, new here cause of problem. I recently had the TF2/Gmod problem, and before knowing it was TF2 I tired changing the launch options to -dxlevel 8, but that didn’t work, removed it, deleted TF2 and it loaded but after that there was some weird drawing problems with DX. Opening new windows inside of Gmod would draw behind it[1]. Notice i opened options and then pressed advanced. Also the server menu stays while laoding into a server [2]. I have a demo : http://rainbowbright.is-a-geek.net/dxprob.dem that outlines some problems that are harder to catch single pictured. Notice the random lines, the Weird polygons in the sky, and blood that has no texture except for wire mesh. Water problem should be darker and not as noticable texture[3]. Console problem[4]. Underwater problem[5]. I tried adding -dxlevel 9 to the launch options but nothing happened, tried different resolutions in either fullscreen/window. Updated DirectX 10 and 9400gt drivers with restart, nothing. New garrysmod folder and nothing still. It seems like it stuck in DX8 or something else, after UI restarted, TF2 was magically reinstalled even after deleting the local content for some reason too. Any ideas? Thanks!

[1] http://rainbowbright.is-a-geek.net/DX89_prob.png
[2] http://rainbowbright.is-a-geek.net/DX89_prob2.png
[3] http://rainbowbright.is-a-geek.net/dxprob3.png
[4] http://rainbowbright.is-a-geek.net/dxprob4.png
[5] http://rainbowbright.is-a-geek.net/dxprob5.png

[editline]09:11PM[/editline]

Guess what? I fail, -dxlevel 81 fixed, though text is a bit different, sorry if you wasted up your time typing up a response :stuck_out_tongue: