DirectX Runtime Errors

I’ve been having some issues with Garry’s Mod lately. The game won’t start up because it tells me that my DirectX Runtime is out of date. However, when I downloaded the installer on the page I was sent to, it told me it’s up to date. I haven’t been able to find much help from page one OR page two(the horror!) of a google search. Any help would be appreciated.

I’m guessing the installer that it linked you to was the Web installer. This usually works, however sometimes it reports that you have the latest version when you actually don’t. To get around this you can run the latest manual installer, I think this is the latest: http://www.microsoft.com/en-us/download/details.aspx?id=8109

I’ve already tried that installer, it didn’t make any difference.

[editline]16th March 2014[/editline]

I’ve solved it. For anyone else who needs a fix for this, download d3dx9_40.dll from this site here http://www.dll-files.com/dllindex/dll-files.shtml?d3dx9_40

Extract the file into the Garry’s Mod folder in Steam, and rename the extracted file so that it has no caps. Worked for me, and this has solved some problems I’ve had with other games as well.