Dirty Bomb

I tried with Ninja Ripper and 3Dripper, and nothing.
It’s based on UE, but Gildor’s tools don’t work for me.

Probably I’m doing something wrong. Anyone has an idea of how to get the models?

No, Gildor has said he hasn’t worked on Dirty Bomb because it has custom compression. It seems to rip textures, but not actual meshes. Beyond that, I’m also stumped on how to get models from this game.

It’s possible let me just say that just requires some effort. I’ve already figured out how to read their encrypted Unreal scripts.

http://puu.sh/kAfNt.png

Year old bump but it looks like someone’s found out how to do it. It’s working like a charm for me as well.

http://puu.sh/oWxxj/6e1f7ac9b6.png

TL;DR from the reddit post:
-Get UEskeletalMeshViewer
-Drag and drop any upk onto it to open it
-Go to your temp folder, find umodel.exe and SDL.dll and copy them somewhere
-Use that version of Umodel to extract Dirty Bomb .upks
-Materials and Textures can be extracted with the current version of Umodel as long as you untick meshes so it doesn’t crash attempting to load them

it works but how to see the skin applied to models?
in 3dsmax i mean i see only skeleton not the skin…like carbon ecc…

that is what i got…the texture dont apply correctly…i try to fix in materials but i cant

http://s33.postimg.org/ob0jt304f/Cattura.png

look how bad the texture is :frowning: why

I want this gun please:

http://vignette2.wikia.nocookie.net/dirtybomb/images/6/68/Ahnuhld-12.png/revision/latest?cb=20151024154116

Can Umodel extract psa animations?

with errur umodel method yes :slight_smile:

What model did you export? There are 2 in there. One is called plasticwax frontend something and has all the bits like helmets, masks, hair etc. The other one only has the main model, usually without hair. It looks like you got that one. Try extracting that one instead or copying the pouches, helmet etc from it and putting it onto this model. The black bits on the texture is where the pouches go on top so they’ve got shadows baked into it.

Also if you extract the skin textures they are very low res for some reason so get the main ones. Skins are applied ingame and there are no separate textures with them, only patterns.

ok now i try with plasitcwax…but for the texture when i extract hig res how to apply?

[editline]26th May 2016[/editline]

when i import platicwax the base texture dont import correctly

It imported fine for me, but I had to extract the textures with the new umodel, or they’d be corrupted.

I just created a multi sub object material and messed with the ids until it all looked right.

yesyes i do that …but just for the basic skin…how to apply others?

What others are you talking about? Do you mean skins like on the lead, iron, bronze, silver etc. cards?

If i apply the yello all fucked up http://s33.postimg.org/n6iyhg9gv/Cattura.png

yes the skin bronze etc

I don’t know how to apply skins because the game does it on the fly. You’d need to use one of the fancy mask textures as a mask to apply the pattern with, but I don’t think it will look any good. Anyway, can’t really help you with that.

okok np…but now what are the appropriate combinations for the materials like material color,specular color etc?

and when i extract .upk with new umodel for hig res skin…they extract 3dsmax material file…we can’t use that?

[editline]26th May 2016[/editline]

in case thanks a lot for all the info… :slight_smile: i hope in the future we discover more info about that

the model material file works bt is very barebones. Better practice to rebuild it by hand. Overall the models seem to extract just fine as fars I can tell

Here

The textures might need some work as the colors look a bit off. I based the colors on this render

yes the model works fine, and yes the material better rebuilt it…now we need just find how to apply texture correctly (and how to extract bushawacker turret model cause the original guys say it not work…maybe with other software)

[editline]26th May 2016[/editline]

errur you need only the scope now on your model :slight_smile:

why you dont accept me on steam friendlist :frowning: pls