Disabling "ammo pickup" display?

Hiya!

I’m a researcher in the process of using HL2 for an upcoming study, but I’m running into a problem. I’m building levels using Hammer (and running them in Gmod). The problem is this: I’m using the Combine Elite enemies in the level… whenever they die, they drop combine balls. And, appropriately enough, it displays “Combine’s Balls” on the right side of the screen (where it displays ammo pickup). I can’t have it saying “Combine’s Balls” when participants are playing this in the lab. So, I need a workaround:

I need to either figure out:

  • how to stop the combine elite from dropping the balls when they die (for some reason, toggling the flag in the properties tab that says “Don’t drop ar2 alt fire” didn’t seem to work).
    or
  • how to stop gmod from displaying whenever ammo is picked up

Suggestions would be greatly appreciated =)

There was a Lua function to disable this, I’ll look for it
EDIT: Got it
ply:SetSuppressPickupNotices( true )

Thanks! After a few hours I ended up giving up and finding a really weak work-around (give the player max ammo for the Ar2 so they don’t pick up the balls as they walk over them, but it’s certainly not an elegant solution)

ply:SetSuppressPickupNotices( true )
Its serverside lua so erm, I’ll give you a example of it



if SERVER then
local ply = player.GetAll
ply:SetSuppressPickupNotices( true )
else
end


Ima test it now
EDIT: That dont work, thinking of something



if SERVER then
    local plys = player.GetAll
    for _,ply in pairs(plys) do
        ply:SetSuppressPickupNotices( true )
    end
end


I think you mean.

Doesn’t works


 language.Add("AR2AltFire", "Energy Ball") 

might work