Displacements giving: "Too many unique texture mappings, max = 2048"

I’m making a snow version of a map, thus there’s quite a bit of displacements. However, none of them go over the brush limit, face, or vertice limit, but I’m getting this error:


Welcome to VBCT
Session Date: Monday, April 18, 2016,  4:43:59 PM
OS = Microsoft Windows NT 6.2.9200.0 = Windows Server 2012 or Windows 8
VBCT Version: 1.0uBETA5


STEAM was found installed at: c:\program files\steam

Garrysmod was selected 
Game name read from gameinfo.txt file: Garry's Mod ... actual mod = Garrysmod
appid read from gameinfo.txt file: 4000
Local SDK Path Profiles were Read!

Source SDK Base 2013 SinglePlayer Games:
  Half-Life 2
  GarrysMod
  Half-Life 2: Episode One
  TextureFormat
  DefaultTextureScale
  GameExe
  DefaultPointEntity
  Vis
  GameExeDir
  BSPDir
  MaterialExcludeCount
  GameData0
  MapFormat
  DefaultLightmapScale
  DefaultSolidEntity
Catch: reading: c:\program files\steam\steamapps\common\Source SDK Base 2013 Singleplayer\bin\GameConfig.txt
  No Source SDK Base 2013 SinglePlayer GameConfig.txt found.

Source SDK Base 2013 MultiPlayer Games:
  No Source SDK Base 2013 MultiPlayer GameConfig.txt found.

Source SDK Base 2009 (common) Half-Life 2 Games:
  No Source SDK Base 2009 (common) GameConfig.txt found.
Left 4 Dead Games:
  No Left 4 Dead GameConfig.txt found.
Left 4 Dead 2 Games:
  No Left 4 Dead 2 GameConfig.txt found.
Left 4 Dead 2 BETA Games:
  No Left 4 Dead 2 BETA GameConfig.txt found.
Portal Games:
  No Portal GameConfig.txt found.
Portal 2 Games:
  No Portal 2 GameConfig.txt found.
Alien Swarm Games:
  No Alien Swarm GameConfig.txt found.
Counter-Strike Global Offensive Games:
  No Counter-Strike Global Offensive GameConfig.txt found.
Counter-Strike Source Games:
  No Counter-Strike Source GameConfig.txt found.
Day of Defeat Source Games:
  No Day of Defeat Source GameConfig.txt found.
Team Fortress 2 Games:
  No Team Fortress 2 GameConfig.txt found.
HalfLife 2 DeathMatch Games:
  No HalfLife 2 DeathMatch GameConfig.txt found.
HalfLife DeathMatch: Source Games:
  No HalfLife DeathMatch: Source GameConfig.txt found.


Fast Compile Selected!

NOTE: old vbsp log file deleted: C:\Program Files\Steam\steamapps\common\Garrysmod\Mapping\rp_industrial17_snow\rp_industrial17_snow_vbsp_old.log

NOTE: existing vbsp log file renamed to : C:\Program Files\Steam\steamapps\common\Garrysmod\Mapping\rp_industrial17_snow\rp_industrial17_snow_vbsp_old.log
Compile Start Time: Monday, April 18, 2016,  4:44:03 PM

-------------- Start Compile BSP ----------------
VBSP Started, Please Wait!

VBSP:  G:\Steam\steamapps\common\Source SDK Base 2013 Singleplayer\bin\vbsp.exe  -game  "G:\Steam\steamapps\common\GarrysMod\garrysmod" "C:\Program Files\Steam\steamapps\common\Garrysmod\Mapping\rp_industrial17_snow\rp_industrial17_snow"

Valve Software - vbsp.exe (Jul 17 2015)
8 threads
materialPath: G:\Steam\steamapps\common\GarrysMod\garrysmod\materials
Loading C:\Program Files\Steam\steamapps\common\Garrysmod\Mapping\rp_industrial17_snow\rp_industrial17_snow.vmf
material "tools/locked" not found.
Material not found!: TOOLS/LOCKED
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Could not locate 'GameData' key in g:\steam\steamapps\common\garrysmod\garrysmod\gameinfo.txt
Patching WVT material: maps/rp_industrial17_snow/nature/blendrocksand004a_wvt_patch
Patching WVT material: maps/rp_industrial17_snow/concrete/blendconcreterock001a_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...Wrote C:\Program Files\Steam\steamapps\common\Garrysmod\Mapping\rp_industrial17_snow\rp_industrial17_snow.lin
Areaportal leak ! File: C:\Program Files\Steam\steamapps\common\Garrysmod\Mapping\rp_industrial17_snow\rp_industrial17_snow.lin 
Brush 4733876: areaportal brush doesn't touch two areas

Brush 845407: areaportal brush doesn't touch two areas

Brush 845322: areaportal brush doesn't touch two areas
done (0)
Building Faces...done (1)
Chop Details...done (0)
Find Visible Detail Sides...
Merged 958 detail faces...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
**Too many unique texture mappings, max = 2048**


Compile Complete for this module.
VBSP Completed: Monday, April 18, 2016,  4:44:11 PM
VBSP: material "tools/locked" not found.
VBSP: Material not found!: TOOLS/LOCKED

VBSP Needs to be run FIRST!!


When I hide Displacements, I don’t run into the error. Most of my displacements are 0 offset and .25 size, all the same. Does anyone know the solution? Can I mod VBSP to ignore this?

[editline]18th April 2016[/editline]

Ok, so I removed some displacements and the error goes away. It’s not just one displacement, it only happens when I do multiple. Do I have to many vertices? My displacements should have the same texture mappings. :? Does it do this because of my alpha drawing on them? I’ll try reducing some of my power of 4 displacements (most are 3 but let’s see anyways).

EDIT 2: Even when majorly reduced to all power of 2, it’s still giving me that texture mappings error. I don’t think it has to do with verts.

EDIT 3: Tested by making all displacements have the same exact texture with the same size and scale.

Is there a limit I’m not seeing here?

try changing the lightmap scale of the texture to 64 or higher :slight_smile:

Made all of the displacements have the same lightmap scale of 64. Still get the glitch.

can you post a few screen shot of the map in hammer ?

fix these and see if anything changes

[editline]19th April 2016[/editline]

Also check decals and overlays on displacements, those can cause errors

Alright, I’ll try removing all the overlays (I do have a lot) on the displacements. (I’ll just remove them all from the map and test to see if it compiles.)

EDIT: That does seem to be the issue here. I have too many overlays on my displacements. :v Guess I’ll have to cut back and do some replacing! Thanks to everyone who replied! :slight_smile: @Tazo & @Grenade Man

Well, looks like that WASN’T the issue. Just removed all overlays and tried to compile and it didn’t work. But it worked when I removed all point entities and readded Lights & NPCs. So it’s a point entitie(s) causing the issue, but’s not overlays, maybe decals?

EDIT: Removed all decals, removed all overlays. Still doesn’t work. I know it’s a POINT entity causing the issue, because when I remove all Point Entities it compiles. EDIT EDIT: Not prop_dynamic, lights, or NPCs.

EDIT EDIT EDIT: Looks like the issue was CUBEMAPS. I removed all of the cubemaps and the map compiled! Where should I go from here? Cutting back on cubemaps? Are cubemaps assigned to certain brush surfaces that they should have not been since I now changed all of the textures to snow textures?

EDIT EDIT EDIT EDIT: ** It’s fixed! ** I fixed the issue by making all of the cubemaps go to default settings. EDIT: Still gives error? Deleting cubemaps solves but resetting doesn’t seem to work anymore.

Did you fix your areaportal issues?

I mean, I can try doing that, of course-- but if the is based around areaportals, I really don’t think it has anything to do with it.

However I’m going to fixing them soon, and who knows, maybe I’ll be wrong.

Leaks, areaportal leaks and other optimization issues tend to break a lot more than just their related system.

Fixed all areaportals, issues are still persistant after I make cubemaps visible again. (I made a visgroup and have them hidden for now and it compiles fine.)

unhide the cubemaps then on the VBSP cmd line try -nodefaultcubemap -game $gamedir $path$file and rebuild when in game :slight_smile:

VBSP: Unknown option “-nodefaultcubemap”

[editline]26th April 2016[/editline]

Do you think I have too many surfaces that accept cubemaps? Meaning I’ve made more “shiny” surfaces and somehow broken a limit?

I think that’s it! I replaced all of my snow textures with a dirt texture and now it works!

Is it possible to modify VBSP to get around this or will I have to reduce? :v Possibly make a nocubemap version of snow I can use for the underground parts.

change the vbsp for this custom one and try the -nodefaultcubemap from http://forum.facepunch.com/showthread.php?t=1413597&highlight=custom+vbsp , i’m not sure of a limit but i played a hl2 mod called hl2 ep3 where one level was complete snow and ice and it was a fairly large level too

Is there a version of that with the entity limit removed(gmod has the entity limit lifted and my map goes beyond entity limit)? The nocubemap fix does work, though-- I think.

no i don’t think there is no limit vbsp for entities, but with Gmod most of the maps have the props added when your playing on the map and not when it being built

EDIT

I think the entity limit is an engine limit not a vbsp one, thats why none has made a no limit vbsp " I think"

The entity limit was modified in Garrysmod to be like 65536 (the maximum value), it was about 8192 on VBSP because that was the default Source limit.

I have a VBSP with that limit removed (someone modified it for me) but I need one with that limit removed and that fix. ;-;