Do you still have the "Green Bar" Chat Bug? I think I may have found a fix!

POSSIBLE FIX:

DELETE the registry tree HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD

So… I have had this stupid chat bug for several months.
I have looked through so many forums, channels, and blogs for an answer, so It’s a miracle I am sane!

(I want to give credit to the person that I found this fix from, but I am currently unable to re-locate the thread/board/message.)

When RUST installs, it creates a REGISTRY TREE and a resultant set of keys, that saves if the game is in full-screen mode, the height and width of the screen manager, what monitor to push the game to and something called skin.jacket. They are all are set to a REG_DWORD type value.

I cannot confirm, but I think the only time the game re-writes these values is if the registry call returns that the object is empty. I do not think that this registry object is updated to any extent after the first install of the game. Hence the reason why you can attempt to uninstall the game, or verify the files, and you still have the same problem.

It would be Interesting to see what the values the program is putting into these REG_DWORD Keys to see what is causing the glitch.

This is what I did:

What I did to fix my game was to DELETE the Registry Tree for Facepunch Studios LTD. I then re-ran the game, and BOOM - Chat fixed.

Registry location to delete: HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD

WARNING: Deleting things from your registry, if you are unaware of what NOT to touch, can be a nightmare. Make a restore point, backup your system, or export a good copy of your registry before you go messing around with it.

DO NOT BLAME ME, if you screw things up, because I AM WARNING YOU NOW TO BE CAREFUL.

One can use their favorite registry editor, to do the dirty deed, or you can copy the text below and save it as a .reg file and then run it.



    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    ;RemoveFacepunch.reg
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    ; Small Registry deletion to remove 
    ; HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD
    ;
    Windows Registry Editor Version 5.00
    [-HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD]
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    ;END of RemoveFacepunch.reg
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-


It would be nice if you explained what this “Green Bar” Chat Bug? is for those of us who don’t know what it is and may encounter it at some point

thx

Sneak,
The best way I can define it, is that your unable to use any bound key to open and send global chat, whispers, or any other kind of plugin commands with the key bound to ‘chat.open.’
Most can escape out of the chat by pressing Escape, however some experience a actual game crash. Some have reported losing other functionality of other bind keys after trying to chat.

Normally, I do not have any kind of colored background when I chat. When I encountered this bug, I had a green background show up in the area where I would attempt to put chat into.
I was unable to press enter to clear the chat, send chat or any type of command.

Here is an example screen shot when I had the issue. --> http://i.imgur.com/OjZVle3.png

I before this fix, I tried switching to DX9, Reloading graphics drivers, reloading / verifying the game cache. Trying the OpenGL switch (it worked, but it was slow as hell.)
I played on several different servers, Vanilla, modded and private, to rule out a plugin or a weird connection issue.
Was told that it was a issue with a third party controller (Like a steam controller or a joystick), yet I have none of those. ( But I reloaded / updated my Chip set, mouse and keyboard on a hail-Mary, no joy…)
I also removed any extra USB crap including My microphone, the android device (Phone) printer, flash drives, et cetera, with no luck.
Tried to load in windows mode, or full screen. I tried simple graphics, all the way to fantastic graphics.
Told it may be a mirror driver (The kind that spyware or remote control software uses.) but after verifying the file system with three different AV / and verifying no R/C software, still no joy.
Pressed the bind key for chat several times, followed by enter quickly, nor trying to shift tab and then shift-tab back, changing resolutions while in game, had any effect for me.
Tried turning chat off, then on… Did the global.chat setting in the .CFG with no luck.
Altered the bind keys in game, and out of game trying to figure out if it was a key-bind issue.

For a long while, in order to chat I pressed the Console bind, and typed chat.say “{Insert some witty text here}” Not good if you see a wolf heading your way.

So that’s what it is in a nut shell. I can only guess at the cause, perhaps it’s a DirectX or Unity overlay issue, and deleting the registry tree forces the game to reset the values.

thx for the low down