Does Crowbar not compile with a model that has additional bones?

Summary:
I have a decompiled SFM model, I rigged it by following Alan 13’s SFM to GMOD video, see here: Conveting model from SFM to Garry's Mod - start to finish [Blender] - YouTube

The model has bones that are outside the body and are written in the .QC I also have a .vta file, but that’s only for the .QC.

Here is the downloadable .QC file: Filebin :: bin 99xdlwhk9yru16y0

I am using the most recent Crowbar version 0.71 (As of time posting).

What I want to achieve:

I want to actually compile the model.

The Error
Here is the compile log, it stops mid way trough and doesent go further than this:

  Building binary model files...
  Working on "hassassin.qc"
  SMD MODEL femassassin_ref.smd
  VTA MODEL hassassin_01.vta
  SMD MODEL hassassin_anims\ragdoll.smd
  SMD MODEL femassassin.smd
  WARNING: Imported bone L_Calf tried to access parent bone L_Thigh and failed!
  Max flex verts 14392
  Processing jointed collision model
  R_Thigh                  (4861 verts, 3 convex elements) volume: 3850.69
  R_Calf                   (3279 verts, 3 convex elements) volume: 1221.55
  R_Foot                   (844 verts, 3 convex elements) volume: 362.58
  L_Thigh                  (2468 verts, 3 convex elements) volume: 3735.44
  L_Calf                   (4904 verts, 3 convex elements) volume: 8117.65
  L_Foot                   (872 verts, 3 convex elements) volume: 363.25
  M_Spine                  (2773 verts, 3 convex elements) volume: 3399.78
  M_Spine1                 (2619 verts, 3 convex elements) volume: 1552.44
  M_Spine2                 (4045 verts, 3 convex elements) volume: 1876.40
  M_Spine3                 (378 verts, 3 convex elements) volume: 409.97
  M_Neck                   (227 verts, 3 convex elements) volume: 320.66
  M_Head                   (1789 verts, 3 convex elements) volume: 795.35
  R_Clavicle               (273 verts, 3 convex elements) volume: 151.78
  R_Trapezius              (1192 verts, 3 convex elements) volume: 421.54
  R_UpperArm               (1870 verts, 3 convex elements) volume: 551.78
  R_Forearm                (1318 verts, 3 convex elements) volume: 261.08
  R_Hand                   (296 verts, 3 convex elements) volume: 46.29
  R_Pinkie_0               (130 verts, 3 convex elements) volume: 5.12
  R_Pinkie_1               (106 verts, 3 convex elements) volume: 0.00
  R_Pinkie_2               ( 82 verts, 3 convex elements) volume: 0.00
  R_Ring_0                 (116 verts, 3 convex elements) volume: 7.08
  R_Ring_1                 ( 80 verts, 3 convex elements) volume: 0.97
  R_Ring_2                 ( 94 verts, 3 convex elements) volume: 0.12
  R_Middle_0               (146 verts, 3 convex elements) volume: 9.40
  R_Middle_1               ( 82 verts, 3 convex elements) volume: 1.44
  R_Middle_2               ( 80 verts, 3 convex elements) volume: 0.79
  R_Index_0                (118 verts, 3 convex elements) volume: 5.15
  R_Index_1                ( 82 verts, 3 convex elements) volume: 0.55
  R_Index_2                ( 76 verts, 3 convex elements) volume: 0.38
  R_Thumb_0                (152 verts, 3 convex elements) volume: 14.79
  R_Thumb_1                (162 verts, 3 convex elements) volume: 8.57
  R_Thumb_2                (144 verts, 3 convex elements) volume: 2.09
  L_Clavicle               (230 verts, 3 convex elements) volume: 133.88
  L_Trapezius              (1191 verts, 3 convex elements) volume: 430.93
  L_Upperarm               (1866 verts, 3 convex elements) volume: 565.79
  L_Forearm                (1274 verts, 3 convex elements) volume: 255.92
  L_Hand                   (348 verts, 3 convex elements) volume: 52.71
  L_Pinkie_0               (146 verts, 3 convex elements) volume: 5.03
  L_Pinkie_1               ( 84 verts, 3 convex elements) volume: 0.00
  L_Pinkie_2               ( 84 verts, 3 convex elements) volume: 0.00
  L_Ring_0                 (136 verts, 3 convex elements) volume: 12.45
  L_Ring_1                 ( 80 verts, 3 convex elements) volume: 0.97
  L_Ring_2                 ( 94 verts, 3 convex elements) volume: 0.12
  L_Middle_0               (158 verts, 3 convex elements) volume: 13.73
  L_Middle_1               ( 82 verts, 3 convex elements) volume: 0.64
  L_Middle_2               ( 80 verts, 3 convex elements) volume: 0.29
  L_Index_0                (112 verts, 3 convex elements) volume: 4.19
  L_Index_1                ( 82 verts, 3 convex elements) volume: 0.55
  L_Index_2                ( 76 verts, 3 convex elements) volume: 0.39
  L_Thumb_0                (152 verts, 3 convex elements) volume: 14.81
  L_Thumb_1                (158 verts, 3 convex elements) volume: 7.29
  L_Thumb_2                (156 verts, 3 convex elements) volume: 2.75
  WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
  WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
  WARNING: Error with convex elements of femassassin.smd, building single convex!!!!
  WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
  WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
  WARNING: Error with convex elements of femassassin.smd, building single convex!!!!
  R_Butt                   (416 verts, 3 convex elements) volume: 555.52
  L_Butt                   (414 verts, 3 convex elements) volume: 512.93

From what I see in HLMV, The butt just extrudes forwards and penetrates the body, and one leg onlyo has the foot rigged, and some bones in the back just appear with the Show Bones option ticked.

It just stops there? Doesn’t it say “Compilation aborted” or something like that? Paste the end of the message, unless it truly just ends there for some reason.

The “Model has 2-dimensional geometry” error is correlated to the collision mesh you made, it is a generic message that can mean a lot of things, but generally it means that a part of the collision mesh is too thin and is considered 2d (or is actually 2d, as in a face)

Check for ripped edges, you can search for “Merge by distance” to merge all ripped edges.
Check for any rogue vertices that may be floating around the model, not attached to anything.

These are the most common, but there are many more smaller reasons which can only be determined by actually seeing the collision mesh, if you could post a screenshot.

1 Like

The message ends there, and Crowbar becomes unresponsive only in the Compile tab. Thank you for helping me.

Something is wrong with your crowbar then, try to update it, also make sure everything is set up correctly, maybe use a difference studiomdl for the compiler, like source film maker’s (you’ll have to download sfm to get its compiler).

1 Like