Downloads are sometimes incomplete ( also incorrect model errors )?

I’m seeing errors being reported across some of uploads that aren’t really there - I can’t replicate them, and the errors don’t exist in the complete code.


Within the last few hours

[!toybox_615_14:118] ')' expected near '<eof>'
[!toybox_615_14:118] ')' expected near '<eof>'
Within the last day

[!toybox_615_14:144] attempt to index field 'Owner' (a nil value)
[!toybox_615_14:144] 'end' expected (to close 'if' at line 127) near '<eof>'
[!toybox_615_14:144] 'end' expected (to close 'if' at line 127) near '<eof>'
Within the last week

[!toybox_615_14:133] unexpected symbol near '<eof>'
[!toybox_615_14:133] unexpected symbol near '<eof>'
[!toybox_615_14:144] attempt to index field 'Owner' (a nil value)
[!toybox_615_14:144] attempt to index field 'Owner' (a nil value)
[!toybox_615_14:133] unexpected symbol near '<eof>'
[!toybox_615_14:133] unexpected symbol near '<eof>'
[!toybox_615_14:107] function arguments expected near '<eof>'
[!toybox_615_14:107] function arguments expected near '<eof>'
[!toybox_615_14:133] 'end' expected (to close 'if' at line 130) near '<eof>'
[!toybox_615_14:133] 'end' expected (to close 'if' at line 130) near '<eof>'
[!toybox_615_14:85] 'end' expected (to close 'if' at line 70) near '<eof>'
[!toybox_615_14:85] 'end' expected (to close 'if' at line 70) near '<eof>'
[!toybox_615_14:132] function arguments expected near '<eof>'
[!toybox_615_14:132] function arguments expected near '<eof>'
[!toybox_615_14:131] attempt to call global 'DamageInfo' (a table value)

Namely the ones about bad syntax ( not sure what is up with the owner or DamageInfo ones ). Those errors do not exist in the full code. It seems that people aren’t getting a full, complete download sometimes?

Also, the midas cannon is getting shat on by model errors that don’t make sense:



rag:SetModel( what:GetModel( ) )


And I’m getting these errors reported:



!toybox_224_3:189] '=' expected near '<eof>'
[!toybox_224_3:191] '(' expected near '<eof>'
[!toybox_224_3:191] '(' expected near '<eof>'
[!toybox_224_3:143] Model missing: models/hunter.mdl
[!toybox_224_3:48] unfinished string near '<eof>'
Within the last day

[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:48] unfinished string near '<eof>'
[@!toybox_224_3:68] Tried to use a NULL entity!
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/nano_suit.mdl
[!toybox_224_3:143] Model missing: models/nano_suit_strength.mdl
[!toybox_224_3:143] Model missing: models/characters/elexis/elexis.mdl
[!toybox_224_3:143] Model missing: models/characters/elexis/naked_elexis.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/taggart/russiand_troopers/visor_soldier.mdl
[!toybox_224_3:143] Model missing: models/taggart/russiand_troopers/goggles_soldier.mdl
[!toybox_224_3:143] Model missing: models/hunter.mdl
[!toybox_224_3:143] Model missing: models/lostcoast/fisherman/fisherman.mdl
[!toybox_224_3:143] Model missing: models/pmc/pmc_2/pmc__02.mdl
[!toybox_224_3:143] Model missing: models/hunter.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:87] attempt to index a nil value
[!toybox_224_3:191] '(' expected near '<eof>'
[!toybox_224_3:191] '(' expected near '<eof>'
[!toybox_224_3:143] Model missing: models/halo2/elite.mdl
[@!toybox_224_3:68] Tried to use a NULL entity!
[!toybox_224_3:87] attempt to index a nil value
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/player/ct_urban_elfa_01.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/hunter.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/humans/deltaforce/male_03.mdl
[!toybox_224_3:143] Model missing: models/zombie/fast_torso.mdl
[!toybox_224_3:143] Model missing: models/zombie/waal.mdl


This doesn’t quite make sense - people are shooting npcs that clearly they have the models for, but it is reporting that the models do not exist.

Install HL2, if it is installed, mount it to gmod

These aren’t my errors.

I got same problem. All my entities and weapons started showing this error on the log. I don’t have a single “&” in my code.

[!toybox_111_10:3] unexpected symbol near ‘&’

I agree with the incomplete downloads statement. It does appear some clients are occasionally getting an incomplete download. My scripts are doing that too.

Yes, incomplete downloads is a problem. I did have code to verify downloads but it isn’t being used. I’ll enable it for the next version.

This appears to still be happening somewhat. Not as frequently though.

Hover over the error, are they on version 99, or 100?

Alright, that last one was version 99, so they just didn’t update I guess.

But that one is version 100.

I’ll have to add a CRC check to all the downloads I think.

Still happening with incomplete downloads, and the model check is still creating errors.


Within the last few minutes

[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
Within the last hour

[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
Within the last few hours

[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:32] Model missing: models/props_fortifications/sandbags_corner1.mdl
[!toybox_1055_3:74] ')' expected near '<eof>'
Within the last day

One of the model errors is from version 99, all the rest are from 100.