DrawBloom does nothing

Hello,

currently I’m trying to use the Global “DrawBloom” for clients, to edit the Bloom settings on them via Lua

My Code looks like this:


function SayBloom(pl, text, txt, teamchat, dead)
	if (string.sub(text, 1, 4) == "/blu") then
		temp = "DrawBloom( 0, 0.75, 3, 3, 2, 3, 255, 255, 255 )"
		BroadcastLua( temp )
		-- return ""
	end

end
hook.Add("PlayerSay", "SayBloom", SayBloom);

But it acctualy does nothing.

I even tryed using DrawBloom via lua_run_cl (it’s a client function doe) in my Console


lua_run_cl DrawBloom( 0, 0.75, 3, 3, 2, 3, 255, 255, 255 )

But that doesn’t do anything, what I’m doing wrong?

New wiki doesn’t provide this info, but it might be useful:

just to be sure your lua_run_cl is an accurate test just be aware of the following:

lua_run_cl is disabled by default.
sv_allowcslua 1

You may or may not already know this, but I’m just making sure.

Acctualy, no.

I can’t hook it via “RenderScreenspaceEffects”, cause I need it to get called on an command.
Or is there a way to do both?
The rest is not realy important, atleast I think so. (Bloom does work at this Machine, args are correct, the rgb values are taken from the wiki)

You can use a variable boolean that the command flips from false to true.

Then in your RenderScreenspaceEffects hook function check if the bloom boolean is set to true, if so run the bloom logic, otherwise don’t.

Introducing Pseudo-code



bMyBloom = false

function myRenderBloom()
     if (bMyBloom) do
          -- Draw bloom
     end
end

function toggleMyBloom()
     bMyBloom = !bMyBloom 
end


Well, you can make a clientside function and activate it using net library

Didn’t know that, thanks.
It’s working now, with console commands.
But it’s weird.
It’s extremly bright, can’t even see anything ( now I get why the numbers shouldn’t be over 1)
But, how should I select the Color of the Bloom effect then?
(Probaly possible by converting the RGB values from 255 to the 0-1 range, isn’t it?)

It’s Pretty sad, that you can’t use normal presets and just load them from lua code.
(It’s probaly do able, but I have no Idea how)

Find the presets here.

I’m either dumb or blind, I don’t know what you want me to tell with that.

I was talking about, that it’s sad, that you can’t load the presets from /settings/presets/bloom/ and just load them in.

I’m still curtious why it’s so extremly bright, but when I select them over the Menu , with Color Values, it’s not.