Dual Weapons - like Max Payne and John Woo

Ever wanted to feel like Max Payne?
Or feel like playing through a John Woo movie?
Or maybe you prefer mixing an accurate sidearm along with a bullet-hose machine pistol?

Well, now all that is possible.

Features:
- Dynamic dual wielding - a M1911 in left hand, a Desert Eagle in right hand, or vice versa, completely up to you!
- Individual ammo pools for each weapon
- Surface penetration
- Surface ricochet
- Custom viewmodel movement
- Custom ammo types
- Custom simple ammo display
- Slight view bob
- Shell ejection
- Designed for both singleplayer and multiplayer
- Particle effects from Firearms: Source 2.0
- An easy-to-use menu to select weapons for your left and right hands
- Currently sporting 13 weapons, which means a total of 169 dual wielding combinations

Known issues:
- M1911 has no dryfire animation (model issue)
- MP5K has no shell eject and muzzle attachments (model issue)

Controls:
PRIMARY ATTACK KEY - fire left weapon
SECONDARY ATTACK KEY - fire right weapon
RELOAD KEY - self-explanatory
CONTEXT MENU KEY (default is C) - open weapon selection menu

To get ammo spawn an Ammo crate in Q > Entities > Dual Weapons Ammo.

Get it here:

Credits:
If you’ve recognized one of the models that are in this pack and have worked on it, rest assured that I take no credit for your work.
I can’t put the credits here because it would use up all available symbols.
The Vman - Firearms: Source 2.0 particle effects

This is fucking amazing. Thanks a million.

the shell ejection looks kind of weird imo, like the shells are too big

Agree. at least they have to be ejected with different angle.

They only look big if you shoot while running forward.

Also, the weapon is listed under Weapons > Other > Dual Weapons in sandbox for anyone that’s wondering. Took me a little while to figure that out :v:

I like the shell size though

I endorse this product

:v:


[Dual Weapons] lua/weapons/dual_weapons/shared.lua:284: bad argument #1 to 'ManipulateBonePosition' (number expected, got nil)
  1. ManipulateBonePosition - [C]:-1
   2. unknown - lua/weapons/dual_weapons/shared.lua:284

Timer Failed! [Simple][@lua/weapons/dual_weapons/shared.lua (line 275)]

That’s the octopus mode feature, did you even read the OP??

You should update your gmod.

When did it happen?

I remember I did something with camera, then returned to firstperson and saw this

Viewmodels don’t show for me. I get this error



[Dual Weapons] lua/weapons/dual_weapons/cl_model.lua:270: bad argument #1 to 'ManipulateBonePosition' (number expected, got nil)
  1. ManipulateBonePosition - [C]:-1
   2. unknown - lua/weapons/dual_weapons/cl_model.lua:270


I think it depends on what playermodel youre using, I was using kleiner when I got the error then I switched to a rebel and everything worked.

Actually I think it just bugs on your initial spawn model, change to anything else and the error will go away.

I tried that, it didn’t work.

I’m at a fucking loss here lol, I’ve no idea why this happens.
I mean, I understand the error, but why it happens - no clue.

I thought Kilburn’s update caused a few bugs concerning bone manipulation and model scaling?

These were developed on the dev build, which is the update that was recently released.

Good news. I managed to fix the problem thanks to a non-retarded discussion comment. Switching both to MR96’s and then to whatever managed to fix the damnedable problem.

I remember downloading this and trying to do dual revolver. The revolvers overlapped perfectly and looked like I was just holding one until I fired/reloaded.