Dynamic Shadows, are they still here?

So, I know that the Source engine has the ability to draw dynamic shadows using a flashlight or lamp. But what if you can’t get those to work? I’ve noticed that whenever I hit the flashlight key (f, by default) no textures light up EXCEPT for certain textures and models like anything made by Maxof2SD, or general eyes on general ragdolls. Same thing with the lamp tool. Do I need a better graphics card? (Running NVidea GeForce 7800gt at the moment, upgrading later.) Or do I need a certain game like Counter Strike: Source or Half Life 2, and its’ two episodes.If so, please tell me because I need them to work for a stop motion animation in GMod I’m working on. If someone could tell me, that would be great. Thanks for reading!

                                                            ~*Senkushi*

[editline]1st December 2012[/editline]

Alright guys, ONE of the at least 13 of you should help. Or you Lizurd Man.

Since you called me out, I’ll say that it’s not your card, since I can remember casting dynamic shadows on my 6800XT almost six years ago. If you are using Garry’s Mod 9 or later(which, you must be), I cannot tell you what the issue is. Make sure all the settings are maxed, even if you think your machine can’t handle them.

The upgrade to lighting came with Episode 2, although, I don’t believe it’s necessary to own Episode 2 to get the newer version of Source lighting in Garry’s Mod.

What he said, make sure your settings are cranked. Also, don’t sign your posts, my first ban was from signing my post awhile back. We know who you are :smile:

Okay then, thanks Lizurd, and sorry 007SILVERSTONE, didn’t know that.

Oh and Lizurd, what do you mean by cranked? Anti-Aliasing and Antriscopic filtering too? Or whatever that is? Or just the things on the first half of the advanced options page.

AA and ASF shouldn’t make a difference, the shadows, reflections, textures, etc. is what you need to worry about.

Okay, done that, but I still don’t get dynamic shadows on most surfaces. Not on construct, flatgrass, or any of the TF2 / Portal maps I have. I only get the shadows on one map I have and that’s gm_fiction. An addon map. And I only get the flashlight / lamp to work on the grass textures.

That sounds like an outdated graphics card to me, I had similar issue before I upgraded like…3 years back

Okay, I figured that. I am upgrading this Christmas, so let’s hope that will do the job. (It can run Crysis 2, max settings, 45 fps, on 150 watts of power.) So yeah. Thanks Lizurd and SILVERTOE, now I know.