Dynamic Shadows - Mobile Graphic cards - Windows 10

**Edited/Updated !!!

**Hello everybody, as some of those people who play the Source engine based games on laptops with dedicated video cards are probably aware of really annoying problem, some of the Source engine games runs only with medium level of shadows which has no dynamic shadows, moreover the high level of shadows option is not even available, you can choose only between low and medium ones. If you type mat_info in console you will see that the game runs on Intel HD video cards which have no dynamic shadows.

As I know it happens if you use video card drivers released for Windows 7, 8, 8.1. The only solution I found was using command in launch options forcing the game to use specific dedicated video card ID.
here is that command: -force_vendor_id 0x10DE -force_device_id 0x1180

If you still have Windows 7, 8 and 8.1 this command can help you to enable dynamic shadows for some Source games, **but still not for Garry’s mod.

**Recently, I upgraded my Windows 8.1 to Windows 10 and videocard driver as well, now I don’t need to use that command anymore, because Garry’s Mod shows Dedicated video card (mine is Ati HD 7600M) in console, it runs on dedicated video card perfectly, new video card driver and Windows 10 detected dedicated video card, in the settings it shows High level of shadows. In my Catalyst Control center hl2.exe (from directory of garry’s mod) is set for “High Performance” which means Dedicated video card, but as I said earlier Windows 10 and new Catalyst driver have no problem with detection dedicated video card for Source games anymore, it’s gone.

**The problem is Garry’s mod stops working right in that moment when I change level of shadows from medium to the highest one while I play, it just gets paused for good. ** Also, no need to use graphic control panel, because video card driver and Windows 10 have no problem with detection of dedicated card for Source games, I guess it’s still the problem of the Source engine Garry’s mod runs on. Even if Garry’s mod runs on dedicated video card it still cannot work with High level of shadows.

To be fair, Source engine doesn’t “detect” video cards - your graphics card drivers do. If a program is assigned a wrong graphics card - you can change which graphics card to use for:

  1. That single program
  2. All programs

using the graphics card control panel.

As for your problem, are you running any addons? Have you tried disabling them temporarily?

I can assure you that addons have nothing to do with that problem, I tried your solution already. Check it in google, type something like “half life 2 no high shadows”, you will see that there are many others having the same problem. Usually I type console command “mat_info” to see which videocard Garry’s mod runs on, with windows 7 and 8.1 it shows Intel HD 4000, with windows 10 it shows HD 7600 Mobility. Yeah you’re right maybe it’s the video card driver and I guess it’s because of the new one released for Windows 10.

Anyway, today I found out that if I run Garry’s mod on Windows 10 and change the shadow settings to medium level (has no dynamic shadows) it works, I can start a new game, load and play it. So I can assure you again Addons have nothing to do with that problem, moreover that problem has nothing to do with “Initializing gaming data” loading process, it works as it should be.

BUT, when I start a new game with medium level of shadows and then changing it to the highest one while I play, Garry’s mod stops working, it just gets paused for good. Also, no need to use graphic control panel, because video card driver and Windows 10 have no problem with detection of dedicated card for Source games, I guess it’s still the problem of the Source engine Garry’s mod runs on. Even if Garry’s mod runs on dedicated video card it still cannot work with High level of shadows.

Seeing as how you’re using an Nvidia Card (I can tell by the Vendor ID), you should be able to set Garry’s Mod to use your dedicated GPU by going to the Nvidia Control Panel > Manage 3D Settings > Program Settings, add hl2.exe from the GarrysMod folder in your Steam/Steamapps/common directory, then set what GPU to use and the settings for it on a per-program basis.

You can also use the Nvidia GeForce program to use the “Optimal Settings” which should include high-level shadowing, considering I can run with it perfectly fine and I’m on a laptop.

I edited the first post to update it with new information, please read it again and I hope other people won’t get confused.

bump