E2 wont work with holo emitter

Hi, I would like some help on this please (if you guys answer questions about wiremod in these forums?). I have tried to use an E2 to make a cool hologram that shows my name when I say /Run. The only problem is, the emitter never emits anything if I use an e2 to define where a point is instead of a gate. The gates work, just not the E2. I have even tried just making the e2 define the variables at the start to see if anything happens, but still nothing. Code (I’m just experimenting right now, so only one point):
@name
@inputs
@outputs X Y Z Local FadeTime Active Color:vector
@persist
@trigger
runOnChat(1)
runOnTick(1)

S=owner():lastSaid()

if (S=="/Run") {Active=1,Local=1,FadeTime=10000,X=0,Y=0,Z=50}

Also, why does my holo just disappear if I set the groundline size to 1? And, could somebody give an example of using the timer in E2 to create certain points, like create 0,0,100 and then 9,0,12 and on and on, to create a specific hologram?

I’m not really good with wiremod, but I think you would be better of asking on the official wiremod forums or something.