EAC + Integrity Error

Hey dudes, whats up?

I was just playing rust yesterday and then I closed it to restart because the fps drop and then I wasn’t able anymore to play. I can’t play in any server, if I try to enter, it gives me the message “EAC Disconnected” or "Integrity Error: Unknown File Version and the way to the “00.content” and “01.content” files.

So I tried to fix that trying every possible way and I cannot fix.

-verify integrity of archives (8 times) that keeps giving me random numbers of corrupted files and then I have to download 1gb of content every time I do it and never fix, I just keep downloading files forever, literally and if I click to verify after correcting the files, it will emerge the same files to download again and again

-run everything with administrator (eac, rust, steam) didnt fix

-reinstall EAC (thousand of times) no results

-reinstall rust (3 times), yeah, I downloaded Rust 3 times, installing and unistalling, no fix

-changing monitor hertz = nothing

-rebooting modem and computer, no results

**- deactivated my firewall too, no results

  • I dont have antivirus so this is not the problem

I tried everything possible and I simply can’t play the game in any server.

I would appreciate any answer from facepunch staff ou experts members from the forum. I have a great team in a great server who is waiting for me.

Thanks in advance and sorry for any english errors.

[editline]10th April 2016[/editline]

Just got this Error. Its rarely occurs. When I don’t get EAC Disconnect, I get this error so I think my chance to play rust it is further than I imagine. I never seen someone getting this error so I decided to post

I tried verify integrity of archives already and didnt solve anything, just keep me giving random numbers of corrupted files whose I have to download over and over again, forever and ever.

[editline]10th April 2016[/editline]

Another brand new error. This is the first time I got it. Apparently only the file way has changed

Let’s look forward for more unprecedented errors.

I did a system recovery and I keep getting the same errors. My hope is slowly going down.

[editline]10th April 2016[/editline]

Its 04/10/16 and I’m lost in the desert.

Apparently the staff doesnt give a fuck, like ever. Or they just don’t have trained programmers for support.

Its 04/11/16 and my legs cannot stand. I cannot fight anymore. I sent a ticket for facepunch but I didn’t get an answer aswell.

There is no hope, probably their laughing now hiding behind the argumentation of “oh, its not our fault, its alpha content” so I paid for a unplayable game. Facepunch hate cheaters but they cheated me.

Why is this happening to me? Is god dead? This is not the first time that Facepunch leaves their customers behind. Actually, they never did nothing for them.

Well one can argue god has been dead or dying since Organon or so but I think your problem has more to do with missing or corrupted files.

Reinstalling obviously hasn’t worked for you so perhaps try something more radical.
Tried wiping your OS? Maybe a different hard drive? Try Linux?

Don’t expect an answer from FP directly in any case. They’re a tiny studio, like less then ten dudes.

Yea, i’m think I will wipe my OS, its my last resort.

Hope at least our facepunch dudes take my prints to study what causes this. Its too complicated to format your PC every time you find an error on Rust.

Thank you for being the only kind soul in this forum.

first up, remember it’s a game; not being able to play for 16 hours isn’t the end of the world, or the final sign for the end of days.

i note that you said you restarted your modem, but have you done a factory reset? sometimes they will hold on to fucked up settings through a restart.

i also note you have no antivirus; do you mean you haven’t had any ever had one on this device, or that you have deactivated/uninstalled it?

if verification is bugging out, you may be better to uninstall entirely, restart the computer then reinstall from scratch. wouldn’t hurt to do the same with EAC, since you seem to have some corrupted files there. i know you have already done this, but you didn’t state that you restarted the computer before reinstalling; sometimes shit can hang around in active memory.

otherwise, i’d suggest waiting patiently for EAC (open a ticket if you haven’t already). they have their hands full with cheaters, and it’s not really their job to address singular errors that are more likely incompatibilities your side (since most other people are not experiencing them). give them time, they are very helpful when they get time to be.

Dude, I wiped my OS

Getting the same errors.

Don’t know what to do anymore.

I WIPED MY OS AND STILL CAN’T PLAY WTF

[editline]11th April 2016[/editline]

well, anyway, I sent a ticket and a dude named Orkel requested the dxdiag.txt and a rust file named output_log.txt.

Let’s see what will happen.

Yes, dxdiag is like lshw. I gotta remember that better.

Did you try installing Linux btw?
You’re problem is almost certainly a hardware issue at this point but it might be worth a go.

Very strange issue. These errors occur when files read from the disk are different than those expected by Rust. Most logical would be some anti-virus software interfering with the system. Otherwise it might also be a corrupted OS (e.g. pirated, unknowingly including malware), or some rootkit virus that comes with any software you’ve installed by default.

I just started getting this error as well, with no idea what is causing it. I was playing last night just before midnight (20 hours ago), maybe gremlins ate something?

I have had no hardware or software changes over the last week (except for a windows update a week ago).

I tried deleting 01.content from the content folder and verify files, but to no luck, error persists.

Error doesnt come when starting the game from shortcut, you can sit in the lobby for hours with no errors, the instant you join a server, it crashes.

Update:

After changing to debug version of Rust and starting the game again, the error sticks but instead of 01.content it now posts it to be 00.content.

Is it possible this could be a Cyclic Redundancy Check Error?

I sent my computer to a expert yesterday. I wiped it like 4 times because some OS errors was occuring and I was unable to install gpu drivers after some point. I will have to pay R$80.00 (25 dollar aprox) to check all hardwares and install all drivers correctly. Maybe that was the problem. My PC will arrive tomorrow. Lets see what will happen

Thanks for the support til now anyway.

[editline]13th April 2016[/editline]

Your error is totally like mine. I was playing normally. When I restarted the game, the errors has begun just like your case.

04/15 update:

Just brought my PC from maintenance. They said my GPU cooler was stopped working they change it. I’m just downloading rust again, if the error disappear, probably was hardware error.

[editline]15th April 2016[/editline]

Same error.

I want a serious help over here. I sent a ticket and that Orkel didn’t help me at all. He just stopped responding me.

Will facepunch solve my problem?

[editline]15th April 2016[/editline]

Also, another error:

I’m stucked, all my friends is playing rust right now and I cannot.

I tried EVERYTHING POSSIBLE, absolutely everything. It seems like somebody blocked my account from playing rust or something like this.

[editline]15th April 2016[/editline]

Update:

Now, everytime I run Rust, it says that DirectX is being configured for the first time.

[editline]15th April 2016[/editline]

I discovered something that might be useful too, I opened the console and this messages was appearing one by one.

Verify Integrity Files is useless, as I said, I will just download unlimited content forever.

Bump.

i get that you are frustrated and keen to play, but the constant bumps bordering on aggressive spam wont help your case.

the error hasn’t really changed, you just have other things going on too.

what did orkel suggest you do?

I just bumped the thread 1 time. I’m just sending the error caracteristics for troubleshooting, actually, i’m trying to help the supporters to solve the problem sending information, that’s all.

Orkel asked me to send dxdiag and output log files to his e-mail and I did it then he asked me if I using a “none” version of beta that I didn’t understand at all so I responded that wiped my OS reinstalling another rust and even so I cannot play.

I sent a PM to him yesterday to check my post here, I think he’s on the way to help me now.

the last 3 posts have come across more like bumps than posts; i’m not trying to pick a fight, just giving you feedback.

from what you have described, i would assume orkel means opting out of betas for rust, which has probably been reset by the total reinstall of your os, and therefore steam; that said, worth a look. right click on rust in your steam library. click properties. go to the betas tab and check out the opt in drop box. you would want it to say “NONE” rather than anything else. if it already says it, great i guess. if not try changing back to NONE and trying to load up again.

Well, I always run on None version but yesterday I tried to run on debug version and staging version with no success. The same errors occurs in both modes.

And again, I have no intention to pick fights, riot or spam. I’m just being as careful as possible to bring information. As I said, I tried everything possible, I searched possible fixes to the problem on web with no success for days. My only alternative is to ask for help to EAC and Facepunch Staff.

I wish I could make a manual download of the files. Could be a fix to the problem.