EasyAntiCheat.sys: kmode exception not handled

Hi guys, I’m on windows 10 and I was running rust flawlessly before, but now when i launch it i get a blue screen, and my pc restarts with the message in the title. any fixes?

Specs:


System Information

  Time of this report: 9/14/2015, 14:25:28
         Machine name: ITAI-PC
     Operating System: Windows 10 Home 64-bit (10.0, Build 10240) (10240.th1.150819-1946)
             Language: English (Regional Setting: English)
  System Manufacturer: To Be Filled By O.E.M.
         System Model: To Be Filled By O.E.M.
                 BIOS: BIOS Date: 07/29/14 21:31:31 Ver: 04.06.05
            Processor: Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz (4 CPUs), ~3.5GHz
               Memory: 8192MB RAM
  Available OS Memory: 8128MB RAM
            Page File: 1812MB used, 14506MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: 12
  DX Setup Parameters: Not found
     User DPI Setting: Using System DPI
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.10240.16384 64bit Unicode

Have you tried unininstalling / reinstalling?

Or even verifying your files in Steam

Same error here :(((((

I have this problem too and its starting to get really frustrating, I love garbage anti cheat software.

[editline]14th September 2015[/editline]

does noone have any sort of idea how to fix this? I’ve tried clean installing easy anti cheat and verifying cache so far, about to try completely reinstalling the whole game.

same problem here.

any news/updates?

Sorry about this happening to you. We’ve pushed an update, could you see if you are able to start the game now?

Could you also screenshot the output of your ‘bcdedit.exe’ command? (http://puu.sh/kbXd1/331bacc20f.png)

games is working for me at the moment. Thanks alot for the help. Il repost if any further problems occur.

Thanks for confirming this back!

I’m having some terrible trouble with what I believe is the same issue. I’ve uninstalled AVG. I’ve uninstalled the game and easy anti cheat. re-installed them. Every time i load rust though steam i get the BSOD. I can load it through the rust.exe file but then it wont let me connect to a server. Getting EAC disconnected (even with steam in the background). I’ve got everything to run as administrator and nothing. Can you please help resolve this?