Editing geometry causing smoothing issues

Ive run into some problems with imported SMDs in 3DSmax and doing various edits, for example when I take an imported mesh and add some detail by connecting or cutting I get areas that have normals that look out of place. Now ive tried using the “Normal” modifier to unify normals, and tried smoothing groups, but to no avail. The areas with new geometry keep looking out of place:

Now, the only way Ive “fixed” this is by exporting the mesh as an SMD, and then re-importing the mesh with “rebuild smoothing normals” unchecked and then applying my smoothing groups again. Would the best way to do geometry edits to imported models is to begin with “rebuild smoothing normals” unchecked when I start? Or is there another way to get around this?

Essentially what you have to do(to get around the import export thing) is to add the edit normals modifier to the stack and reset them all. After that you can collapse the stack to it and use polygon smoothing for the normals.