Egad! - Customizable Admin Derma

Welcome to the wonderful world of the** Entirely Generic Administration Derma!** (and because E is superfluous, it’s mostly just called the GAD)

Have you ever been using admin mods such as ULX or ASSMod and simply were not satisfied by the derma? Ever though there was more to life than an endless labyrinth of scrolldown menus or seas of buttons?

Well now there is! The GAD incorporates a familiar ULX-ish design with new innovations (sorry ASSMod, I hate your menu) to create the best administrating experience you could ask for, while allowing the old schoolers to keep with the times. ** The GAD isn’t a whole new admin mod, just a derma preferable to the existing administration menus.**

NEW FEATURES:
**** Compact design**: GAD is a relatively lightweight derma and takes up little space considering its content.

**** Customization:** The GAD is made to be easily customizable to even those who have hardly spared a glance for a LUA file before. Along with prebuilt customization for both ULX and ASSmod, it’s only a step away from configuration to any other mod you can think of.

**** Model Panel:** Sneakily hidden in the client panel, the GAD features an animated panel that allows you to view and set both the model and color of a player.

**** Map Viewing:** The GAD comes with not one, but two ways of changing your maps. Along with the traditional rows of buttons, the new “List View” menu uses advanced imaging technology to create a picture to go along with all of your maps (a.k.a. DImage + spawnicons). Both map menus now include an easy to use map timer.

**** Web Browsing:** Bring your internet into the internet! The GAD now allows for web browsing across the entire internet into places such as Google, Youtube, or even Facepunch. You can even bookmark your favorite sites for later.

**** File Browsing:** Utilize several different types of files, from mp3s to models to text files. All current supported files are: .mp3, .wav, .mdl, .vtf, and .txt.

**** Security:**In order to keep your server safe, the GAD smoothly supplements the existing admin mod without intruding upon the server core. All administration functions are safeguarded against non-admins, and convar access is limited to super admins.

Here’s some nice pictures to look at:

[

WHAT’S TO COME:

**** New looks:** I need to change the look of the client panel (too many buttons). Have any suggestions? Tell me please!

There you have it folks, the Entirely Generic Admin Derma. Download it here:

[http://www.garrysmod.org/img/?t=dll&id=70555

Or get it on the SVN: http://egad.googlecode.com/svn/trunk/ egad

HOW TO CUSTOMIZE THE GAD:

In the /lua/autorun of the .zip, there’s a file called “gadcfg.lua”. This is for all of the configuration used for the GAD.
DO NOT EDIT THE “gadmenu.lua” FILE UNLESS YOU KNOW WHAT YOU’RE DOING!

Once you’re in the cfg file, it’s pretty self explanatory. Refer to the Table of Contents as to the location of things. As explained in the first few lines, there are already prewritten configurations for both ASSMod and ULX. To activate these configurations, you change the variable at the very top called “mod.Name” to equal “ULX” or “ASSmod”.

If you want to use another admin mod (NewAdmin [which I’ll make a config for eventually], Moocow, or even your own custom mod), follow the steps outlined in the explanations above each table.

SOME LAST THOUGHTS:

**** The Admin Menu vars:** One thing I noticed upon programming this is that by default, a good bit of the sbox_maxwhatevers were “” usually. (i.e. sbox_maxballoons, sbox_maxbuttons, etc.)
So to fix this, I gave each variable a default value to set upon opening the menu if there were no default values. However, you can turn this off if you don’t want limits by setting the mod.AutoLimitConVars to zero.

**** The Web Menu:** The address bar is made to work so you shouldn’t have to input the “http://” along with your address code, but you might want to do it if you needs to use a https connection. Also, I don’t think a “Back” or “Forward” button is feasible considering there’s no way to store the URL upon changing it by clicking a button in the page.

**** The Title:** It says “ASSMod Main Menu” because it takes on the title of whatever is the name of the admin mod you’re harnessing.

**** Where it’s supposed to be:** Most of the clientside functions and the map function work from the client, but ALL ADMIN FUNCTIONS + MODEL PANEL FUNCTIONS REQUIRE THIS TO BE ON A SERVER, NOT A CLIENT!

*************** HOW TO USE **************** Copypaste everything in the download into your garrysmod directory! Type “gadmenu” in console!

[release]:siren: **


TROUBLESHOOTING**

:siren:
1. When I type “gadmenu” in console it isn’t working?

  • Are you sure you’re typing exactly “gadmenu” in console?
  • Are you sure that the gadmenu.lua and the gadcfg.lua are in your or the server’s /lua/autorun/client directories?
    2. Some of the buttons don’t work! (“Unknown console command: gad_rcon”)
  • This is because your GAD is not functioning off of a server! The only way to set convars is via the game console, and I didn’t want to have to use regular rcon and get everyone banned from the servers.
    3. I changed the mod name, but it’s still showing/doing the same thing!
  • The script doesn’t automatically update itself, so you have to either restart your Garry’s Mod or type this in console:
    “lua_openscript_cl autorun/client/gadmenu.lua” if you’re running it off your client
    “rcon lua_openscript autorun/client/gadmenu.lua” if you’re running it off the server
    **4. Some of the icons won’t show up! **
  • This is because you either didn’t put the custom GAD icons in the /material/gui directory, or you’re missing the default silkicons.
    [/release]

Looking VERY nice… I’ll edit this later on how I think of it.

Edit:
Gadmenu didn’t work in console, wonder why…

One of the best Admin Hud’s ive seen yet, could be alittle bigger in size for the box though, unless it’s expandable? +Gold Star.

Which admin modes i need? Or this is another?

Finally a sexy menu I can use with my admin mod.

Definitely a lot better then the menu I made.

http://i44.tinypic.com/21d4sc2.png :v:

God damn! Seems awesome.

Doesnt seem to work for ULX, i dont know about ASSmod, but it doesnt work for ULX.

ahem… you are luaizing even your info.txt
info.lua -> info.txt
changelog.lua -> changelog.txt
unless you are a lua freak V:

Rly nice and usefull addon!

//Ilol’d
My map at the picture :smiley:

ARRGH. I’ll take a look.
If it’s not working in your addons, try sticking gadcfg.lua and gadmenu.lua in your /lua/autorun/client for now until I fix the problem.

“The GAD isn’t a whole new admin mod, just a derma preferable to the existing administration menus.”

The whole point is you can use ANY admin mod you want. ASSMod and ULX have prewritten configurations (although apparently ULX isn’t working? I’ll check that…), but you can easily configure any admin mod to it so long as it has console commands.

xD Never noticed that… changed

That looks very very nice. If I had a server I would probably use this actually, but I don’t so…:sax:

The info.lua should be info.txt.

Oh and:

http://img140.imageshack.us/img140/5237/tmpzbam9.jpg

And even though specified it still shows up as the assmod version:

http://img219.imageshack.us/img219/6094/tmpki3bx.jpg

Did I do something wrong there?

Hmmmm.

Ok, something’s wrong here. For whatever reason, when this goes in your addons it doesn’t work. Period. I have no clue what I did (I could have sworn it worked before), but it doesn’t work.

IMPORTANT**
This should fix it! I’ve updated the download and now here’s what you need to do:

Download from from here:
http://www.garrysmod.org/img/?t=dll&id=69156

And copypaste the contents (except the info/changelog) straight into your garrysmod directory.

Also, Smoot, the bottom missing textures should be fixed, but to the best of my knowledge the ones on the top are regular silkicons. You should have them. I guess I could stick 'em in the next revision though if a bunch of people are missing them. As for your naming issue, try downloading the new version and see if it works any better. Remember, just saving the file won’t make the menu change instantaneously, you have to either restart gmod or use “lua_openscript_cl autorun/client/gadmenu.lua”

And lastly, Wizey, it works now with ULX.

-snip-

“gadmenu” still doesn’t work in the console for me.

GAWDAMNIT

I just realized the new download doesn’t have it in the client folder.

sigh Give me a sec to fix the download.

ONE LAST TIME, THE DOWNLOAD SHOULD SERIOUSLY FO REALZ BE FIXED:
http://www.garrysmod.org/img/?t=dll&id=69156

Sorry about all. This is my first true release, so I keep forgetting where shit goes.

I updated the download in the news post to prevent any further trouble.

It still doesn’t work. at least for me. I put materials and lua in the garrysmod folder. gadmenu still doesn’t work.

Bear in mind you have to restart GMod for it to work, or type this in console:

lua_openscript_cl autorun/client/gadmenu.lua

okay got it running :). But in the web browser i can’t type in text boxes on web pages.